Cant move in Eodon and Blackthorn.

Moti

Citizen
Nov 8, 2017
6
0
1
38
Hi to all.Have some problems.Im in owner and player mode cant move in eodon and blackthorn locations.Only teleport in owner mode.Im see work spawn,but mobs also cant move.Have latest version uo client and normal played in other shard when have Eodon.For exemple Alexandria and Trueuo.Dont have errors in load ServUo.Plz help.
(P.S Dear Dex,do not forget our Lexia)
 
Last edited:

Moti

Citizen
Nov 8, 2017
6
0
1
38
7.0.74.28 my UO client.And im load Servuo from download menu.And publish 55.1 from news and updates.
 

Moti

Citizen
Nov 8, 2017
6
0
1
38
Yes.Im use game client for game and for servuo on my general comp.Uncomment line with this path.But from my other computers with latest version uo client also this problem when im connect on my shard.
 

Moti

Citizen
Nov 8, 2017
6
0
1
38
Yes,im patch from osi always.All paths are correct, I have only one folder of a classic client. I just discovered that - I can move in a building in Eodon, but I cannot move on the ground, what could it be?(Use razor for connect)May be somthing change in my server?In other windows my chay cant problem and move in Eodon on Uo Heritage.
 
Last edited:

Milva

Admin
Moderator
Mar 3, 2013
4,525
570
113
Donate
Donate money to this user
On razor- check to be sure both these are pointed to your
UO client
Load Client
and UO Data Directory
If both are pointed to your game client, then I'm not sure what the problem could be.
 

Moti

Citizen
Nov 8, 2017
6
0
1
38
maybe you need to configure something in my server?((Also noncorrectly work multi teleport in eodon,noncorrectly coordinate.
[doublepost=1549506831][/doublepost]Find error.Need del old version mul files.All works.Thanks for yours job.
 
Last edited:

christoper plo

Citizen
Dec 24, 2014
5
0
1
41
if map*.mul files is in directory(Program Files (x86)\Electronic Arts\Ultima Online Classic??),
<for easy uo mining? >

eodon tile data is incorrectly translate(?)


all tile -> wall, impassible
 

Silent Hill

Citizen
Mar 5, 2017
19
2
3
38
I took a little time off but have returned to servuo, and I'm having this same issue still. The entire game works perfectly everywhere but when I step out of the Eodon moongate, or use the Moonstone I can't move. Also when I spawned the world, all of the NPCs for each place also can't move. They're all stacked on top of each other. Any thoughts ?
 

Falkor

Squire
Apr 11, 2018
415
158
43
wpshard.com
Shard Name
Whispering Pines
Your server needs its own copy of the game client (not the same folder you play from) and it needs to be identical in both locations. Then be sure that it is pointed to that folder for the game files *and* that the settings in MapDefinitions.cs are set properly.

Code:
            TileMatrixPatch.Enabled = false; // OSI Client Patch 6.0.0.0

            MultiComponentList.PostHSFormat = true; // OSI Client Patch 7.0.9.0
Note any errors or important messages in the console window while the shard is starting up.
 

Silent Hill

Citizen
Mar 5, 2017
19
2
3
38
No errors or messages during server start. I'm afraid I'm not that adept at messing with any .cs files though. I have the serv uo folder unzipped directly into my main client folder though, so I thought it would have access to everything it requires ?
 

Silent Hill

Citizen
Mar 5, 2017
19
2
3
38
if map*.mul files is in directory(Program Files (x86)\Electronic Arts\Ultima Online Classic??),
<for easy uo mining? >

eodon tile data is incorrectly translate(?)


all tile -> wall, impassible
This reply appears to be the issue, but I"m not sure what your response is saying to do because of language barrier. Can anyone else explain how to fix this eodon tile impassible issue ? It not only affects my admin account, but the NPCs that all spawn are all standing on a single tile. If I use the [tele command it doesn't send me to the cursor spot I click on but another location near there, where I continue to not be able to move. This only happens on Eodon tiles, every other facet works perfectly.
Post automatically merged:

Your server needs its own copy of the game client (not the same folder you play from) and it needs to be identical in both locations. Then be sure that it is pointed to that folder for the game files *and* that the settings in MapDefinitions.cs are set properly.

Code:
            TileMatrixPatch.Enabled = false; // OSI Client Patch 6.0.0.0

            MultiComponentList.PostHSFormat = true; // OSI Client Patch 7.0.9.0
Note any errors or important messages in the console window while the shard is starting up.
Ok so MapDefinitions.cs doesn't even have Eodon listed, which of course explains everything. I don't understand why it doesn't though ?
 
Last edited:

Silent Hill

Citizen
Mar 5, 2017
19
2
3
38
One of my posts above has the uo client link, I would download a new client, Or check your game client to patch it up
Fully patched, and I still play on OSI shards occasionally. I think the issue is the missing Eodon line, which is weird because the TOL expansion is active. I was able to use the Moonstone to travel to Shadowguard, but couldn't move once there. I had to tele forward through the shield teleporters then once I got inside I could do all of the rooms normally, but otherwise every location I go to all I can do is turn around in place.
 

Falkor

Squire
Apr 11, 2018
415
158
43
wpshard.com
Shard Name
Whispering Pines
The server either can't see the map files or it is interpreting them incorrectly which is why nobody can move over newer textures.

Make a directory for the server's client, say C:\ServerUOClient. Copy your entire client folder to that location. Now the server has files it can read without conflict if you're also playing from the same machine. The root of the drive is important beacuse Windows just loves to impose arbitrary restrictions on what can be read or executed from various user folder locations.

Edit /Config/DataPath.cfg to reflect
Code:
CustomPath=C:\ServerUOClient
Then you MUST make sure the TileMatrix settings are correct in MapDefinitions.cs or the server will not correctly interpret land tiles.

You don't have a separate listing for Eodon because it isn't a separate map. It's a region of the TerMur map.
 

Silent Hill

Citizen
Mar 5, 2017
19
2
3
38
I appreciate your help but im completely at a loss now. I created the new folder just like you suggested, changed the DataPath.cfg correctly, I made no changes to MapDefinitions.cs as I never changed them originally, the server started throwing errors regarding what I"m assuming are random Lost items, these would never stop so I reverted it back to where it was, I'm still stuck.
 

Falkor

Squire
Apr 11, 2018
415
158
43
wpshard.com
Shard Name
Whispering Pines
If you refuse to do all of it, then there's nothing we can do to help you.

Without the proper settings in MapDefinistions.cs, the server doesn't properly interpret item and land tiles.

If the last client you did this with was 7.0.9 or older, then you didn't have to do the change there. Now you do. It's as simple as that.