CentrED server created xml but now shuts down right after launch

Bonaccorso

Citizen
Hi, I tried to install CentrED as by tutorial in topic here; it created xml file with this content:
XML:
<?xml version="1.0"?>
<CEDConfig Version="6">
  <Language>..\Language\English.ini</Language>
  <Port>2593</Port>
  <Map>
    <Map>C:\Games\Electronic Arts\Ultima Online Classic\map0.mul</Map>
    <StaIdx>C:\Games\Electronic Arts\Ultima Online Classic\staidx0.mul</StaIdx>
    <Statics>C:\Games\Electronic Arts\Ultima Online Classic\statics0.mul</Statics>
    <Width>896</Width>
    <Height>512</Height>
    <Prefix></Prefix>
    <Format>0x0000001C</Format>
  </Map>
  <Tiledata>C:\Games\Electronic Arts\Ultima Online Classic\tiledata.mul</Tiledata>
  <Radarcol>C:\Games\Electronic Arts\Ultima Online Classic\radarcol.mul</Radarcol>
  <Accounts>
    <Account>
      <Name>Admin</Name>
      <PasswordHash>89fbe5e6b40ef061fe49a86d78cc3bd4</PasswordHash>
      <AccessLevel>255</AccessLevel>
      <LastPos x="0" y="0"/>
      <Regions/>
    </Account>
  </Accounts>
  <Regions/>
</CEDConfig>

but after I input admin login and password during the creation, it instantly shut down, and now shuts down in every launch.

I tried launching server as admin and with compatilibities, but no result.

My version of the client is 7.0.86.2 if it's important.

I tried to find what can be wrong, but no result so far :-(
 
other the directories differences, I have this:

XML:
  <Port>2597</Port>


    <Prefix>0</Prefix>
    <Format>0x00000000</Format>

My batch to start server:

Code:
cmd /k C:\UOBin\CentrED+\PEBinaries\cedserver.exe map0.xml

Only other guess would be client or server cant find the mul files.
 

Bonaccorso

Citizen
other the directories differences, I have this:

XML:
  <Port>2597</Port>


    <Prefix>0</Prefix>
    <Format>0x00000000</Format>

My batch to start server:

Code:
cmd /k C:\UOBin\CentrED+\PEBinaries\cedserver.exe map0.xml

Only other guess would be client or server cant find the mul files.

I think I tried 2597 with the same result - but you are right about mul's. Now those links are on converted muls (as new clients have UOPs instead), and it seems that they have some difference in size (CentrED guide has a lot about the sizes of various mul files, and my don't match any) and format (0x0000001C and so on) from what they should be, thus preventing CentrEd from working properly.

If you don't mind, what version is your client?
 
Sorry, the above was for an old version I was using. For Classic, I have used this (client 7.0.87.11):

XML:
<?xml version="1.0"?>
<CEDConfig Version="6">
  <Language>..\Language\English.ini</Language>
  <Port>2597</Port>
  <Map>
    <Map>C:\Program Files (x86)\Electronic Arts\Ultima Online Classic\map0LegacyMUL.uop</Map>
    <StaIdx>C:\Program Files (x86)\Electronic Arts\Ultima Online Classic\staidx0.mul</StaIdx>
    <Statics>C:\Program Files (x86)\Electronic Arts\Ultima Online Classic\statics0.mul</Statics>
    <Width>896</Width>
    <Height>512</Height>
    <Prefix>0</Prefix>
    <Format>0x0000001C</Format>
  </Map>
  <Tiledata>C:\Program Files (x86)\Electronic Arts\Ultima Online Classic\tiledata.mul</Tiledata>
  <Radarcol>C:\Program Files (x86)\Electronic Arts\Ultima Online Classic\radarcol.mul</Radarcol>
  <Accounts>
    <Account>
      <Name>admin</Name>
      <PasswordHash>xxx</PasswordHash>
      <AccessLevel>255</AccessLevel>
      <LastPos x="1400" y="1664"/>
      <Regions/>
    </Account>
  </Accounts>
  <Regions/>
</CEDConfig>

but I guess I havent gotten it working with a UOP to MUL, I get bad MUL/size. :(
 

Bonaccorso

Citizen
Sorry, the above was for an old version I was using. For Classic, I have used this (client 7.0.87.11):

XML:
<?xml version="1.0"?>
<CEDConfig Version="6">
  <Language>..\Language\English.ini</Language>
  <Port>2597</Port>
  <Map>
    <Map>C:\Program Files (x86)\Electronic Arts\Ultima Online Classic\map0LegacyMUL.uop</Map>
    <StaIdx>C:\Program Files (x86)\Electronic Arts\Ultima Online Classic\staidx0.mul</StaIdx>
    <Statics>C:\Program Files (x86)\Electronic Arts\Ultima Online Classic\statics0.mul</Statics>
    <Width>896</Width>
    <Height>512</Height>
    <Prefix>0</Prefix>
    <Format>0x0000001C</Format>
  </Map>
  <Tiledata>C:\Program Files (x86)\Electronic Arts\Ultima Online Classic\tiledata.mul</Tiledata>
  <Radarcol>C:\Program Files (x86)\Electronic Arts\Ultima Online Classic\radarcol.mul</Radarcol>
  <Accounts>
    <Account>
      <Name>admin</Name>
      <PasswordHash>xxx</PasswordHash>
      <AccessLevel>255</AccessLevel>
      <LastPos x="1400" y="1664"/>
      <Regions/>
    </Account>
  </Accounts>
  <Regions/>
</CEDConfig>

but I guess I havent gotten it working with a UOP to MUL, I get bad MUL/size. :(
Yeah, didn't work for me either, CentrED server won't start.
 

Bonaccorso

Citizen
Startup batch file?

Code:
cmd /k C:\UOBin\CentrED+\PEBinaries\cedserver.exe map0.xml

I'll try, but it seems to be a client mul files issue: when I use CentrED with 7.0.20, it's alright, but with 7.0.68 for example, I unpack MULs from UOPs, and server won't start - window appears for just a moment.
 

golfin

Rookie
Dude, I already said that somewhere. New map files have different sizes. therefore, it does not start in CentrEd. Don't try at all. Just use an older map that will be either Pre ML: 77,070,336 bytes or Post ML: 89,915,392 bytes in size. The new files for the new client versions are different and larger. I do not recommend using new versions of UO, I recommend using versions up to 7.0.59. Newer ones will only bring you trouble.
 

dandanilo

Citizen
Hey,

What golfin said is the key!

My suggestion:

- First convert your map0legacymul.uop to map0.mul;
- Check the map0.mul file size.

1602074662038.png

If your map0.mul is 77.070.336 bytes than you should place the:

<Width>768</Width>
<Height>512</Height>

If your map0.mul is 89.915.392 bytes than you should place the:

<Width>896</Width>
<Height>512</Height>

- I suggest strongly you to use the Format of:

<Format>0x0000000C</Format>

Considering that you are using the most up-to-date UO files.

Let me share my xml file so you can take a look:

Code:
<?xml version="1.0"?>
<CEDConfig Version="6">

  <Language>..\Language\English.ini</Language>
  <Port>2597</Port>
  
<Map>
    <Map>D:\Arquivos Danilo\Pessoal\UO\CentrED\Arquivos\map0.mul</Map>
    <StaIdx>D:\Arquivos Danilo\Pessoal\UO\CentrED\Arquivos\staidx0.mul</StaIdx>
    <Statics>D:\Arquivos Danilo\Pessoal\UO\CentrED\Arquivos\statics0.mul</Statics>

    <Width>768</Width>
    <Height>512</Height>
    <Prefix>0</Prefix>
    <Format>0x0000000C</Format>

  </Map>
  <Tiledata>D:\Arquivos Danilo\Pessoal\UO\CentrED\Arquivos\tiledata.mul</Tiledata>
  <Radarcol>D:\Arquivos Danilo\Pessoal\UO\CentrED\Arquivos\radarcol.mul</Radarcol>

  <Accounts>
    <Account>
      <Name>dandanilo</Name>
      <PasswordHash>d7dcd79b773dc85c89b84862cdedb6cf</PasswordHash>
      <AccessLevel>255</AccessLevel>
      <LastPos x="3384" y="1968"/>
      <Regions/>
    </Account>
  </Accounts>
  <Regions/>

</CEDConfig>
Post automatically merged:

This guy made a post very instructive on how to run a CedServer:


Cheers!
 

golfin

Rookie
And if its size is 89,915,588, you won't do anything about it and you won't open it in the center.
 

dandanilo

Citizen
I have not tried that, I don't use that size, but if you are saying it does not open than I believe in you.
Mine is Pre-ML so it fits well. :p

The fact is: CentrED+ needs to be updated...
It does not deal with High Seas art (the item tab stops in the 16k count in art.mul, you cannot add art that are after this item count) and it has these problems with mapsize that you are pointing and I did not knew...
 

golfin

Rookie
He also has other problems, such as global operations. These create errors on the map for several people. But the original center project should be flawless.
 

Vierhand

Citizen
Dude, I already said that somewhere. New map files have different sizes. therefore, it does not start in CentrEd. Don't try at all. Just use an older map that will be either Pre ML: 77,070,336 bytes or Post ML: 89,915,392 bytes in size. The new files for the new client versions are different and larger. I do not recommend using new versions of UO, I recommend using versions up to 7.0.59. Newer ones will only bring you trouble.
Where can i get the 7.0.59 client? I´ve only the Autopatcher and i don´t know how to stop it by this version.
With that client Centred+ should run?

Thank you :)
 

Bonaccorso

Citizen
Where can i get the 7.0.59 client? I´ve only the Autopatcher and i don´t know how to stop it by this version.
With that client Centred+ should run?

Thank you :)
For CentrED I use 7.0.20 version - and than just pack its changed MULs into UOPs for 7.0.68 (likely, I dont remember exact version but late one) which I play. I never tried to use the patcher yet, I just downloaded 7.0.20; there was a link somewhere on the forum. If you won't find it, I can uplod it on google drive.
 

Vierhand

Citizen
For CentrED I use 7.0.20 version - and than just pack its changed MULs into UOPs for 7.0.68 (likely, I dont remember exact version but late one) which I play. I never tried to use the patcher yet, I just downloaded 7.0.20; there was a link somewhere on the forum. If you won't find it, I can uplod it on google drive.
That would be very nice, thanks
 

Vierhand

Citizen
So, i found a 7.0.20 client and also InsideUO runs on this version :)
Do you know or do you have an instruction how i can convert my "old" data (map.mul, ...) into uop to play with the newest version 7.0.68?

THANKS a lot
 

sec_goat

Citizen
So, i found a 7.0.20 client and also InsideUO runs on this version :)
Do you know or do you have an instruction how i can convert my "old" data (map.mul, ...) into uop to play with the newest version 7.0.68?

THANKS a lot
Get UO Fiddler https://github.com/polserver/UOFiddler/releases/tag/4.9.3 and enable the UOPacker plugin, then use that to convert the file, I however do not have this 100%, when loading the map file back into client and server it appears to work but i will often dissapear off the map and into black