Disconnect after login on public ip

Psych0

Citizen
Apr 11, 2020
11
3
3
Hello everybody. I installed servuo on a debian 9.6 following a guide found on this site.

I configured the server and started, opened the ports on my router to connect from the outside (I'm creating a server to play with a couple of friends).

if I log in from my local network I connect correctly and create the character, while if I switch from the public IP I log in and everything is fine and I see the server but as soon as I click on the server name on the console I see directly disconnected. same thing my friends enter and create the account without problems but as soon as they click on the server name I see on the console disconnected while they remain in connection until the time out

I notice that when the server starts it detects my public ip (which I also wrote on the config file) but in listening I only see my private address. the strange thing that the connection and the generation of the account allows it from the public ip. can someone help me?
 

PyrO

Moderator
Jan 27, 2015
1,319
172
63
is the # still infront of your fixed ip? It should listen automatically to the correct ip didnt have issues under linux.

Anyway, the server itself kinda does 2 things at once, login server and the game server. thats why you can connect to the first, and see the server list.
But in the server list you get a wrong ip, probably the local one from your server, wich means your client tries to connect to the local ip, in its own network wich will then result in not working.
 

Psych0

Citizen
Apr 11, 2020
11
3
3
magically today the problem has solved itself. I do not know what to say. thanks anyway for the help :)
 

Psych0

Citizen
Apr 11, 2020
11
3
3
yes the router, firewall and iptables configuration has been done correctly. as I said earlier this morning when I went to the PC I saw that magically everything worked correctly. I suspect some problem with the isp
 
  • Like
Reactions: Ozzer2016