Housing problem(new to all of this)

Mukyluk

Citizen
First let me say I'm new to all of this. I've been trying to get a server running on my pc for a couple of days. I have it up and running. The problem I'm running into is when I place a house I or anyone can't enter the house. It's like I'm still walking on the ground and not the floor of the house. I'm standing on the ground under the house instead of on the floor. Also some houses (mainly old school houses) it tells you "You don't have access to this." Trying to place a custom house is even worse. I get the plot but no sign or anything to it. Those I can't even demolish. Any advice on what i need to do. I followed the instruction from "ItWouldBeWise" from youtube.
 

Milva

Administrator
Moderator
Check your datapath.cs script to be sure it's pointed to the game client correct- also what would your game client patch be at if low patch it up?
 

Mukyluk

Citizen
private static readonly string CustomPath = Config.Get("DataPath.CustomPath", null);
private static readonly bool IgnoreStandardPaths = Config.Get("DataPath.IgnoreStandardPaths", false);

That is the part you are referring to correct? My client patch is "Customized 5.0.8.3 (Patch 204). Not sure if you just wanted patch or all of that, but thank you for reply and help.
 

Milva

Administrator
Moderator
Correct it should look like this (depending on where your game client is located
private static readonly string CustomPath [email protected]"C:\Program Files\Ultima Online";

That patch is very low-do you want it this low? Most are now using up to 7.0.50.0
 

Mukyluk

Citizen
Ok, thank you. I'll change that path. As far as the patch I get a massage that it is restricted to that. Not sure why or how thou. How would I update that. Again, I'm very new to this.
 

Hammerhand

Rookie
In Scripts/Misc/ClientVerification.cs you can change line # 12 to stop that restricted message.
Just change the true
Code:
private static readonly bool m_DetectClientRequirement = true;
to false
Code:
private static readonly bool m_DetectClientRequirement = false;
and save it. Now, when booting the server, you wont have that annoying "restricted" message everyone loves so much. :D
 

Boss

Citizen
map definitions

TileMatrixPatch.Enabled = false; // OSI Client Patch 6.0.0.0

MultiComponentList.PostHSFormat = true; // OSI Client Patch 7.0.9.0

something along these 2 lines, i have runuo so sorry if its off :(
 

dmurphy

Administrator
ServUO Developer
You should be using the configuration files in the config folder. There is a setting in them for client file locations.​
 

Mukyluk

Citizen
private static readonly string CustomPath = Config.Get("DataPath.CustomPath", null);
private static readonly bool IgnoreStandardPaths = Config.Get("DataPath.IgnoreStandardPaths", false);

That is the part you are referring to correct? My client patch is "Customized 5.0.8.3 (Patch 204). Not sure if you just wanted patch or all of that, but thank you for reply and help.
Ok, I tried updating the path and this didn't fix the problem with houses. Anything else I should try?
[doublepost=1472690034][/doublepost]
map definitions

TileMatrixPatch.Enabled = false; // OSI Client Patch 6.0.0.0

MultiComponentList.PostHSFormat = true; // OSI Client Patch 7.0.9.0

something along these 2 lines, i have runuo so sorry if its off :(

I checked the files and there are set just as you have them above.
[doublepost=1472690101][/doublepost]
In Scripts/Misc/ClientVerification.cs you can change line # 12 to stop that restricted message.
Just change the true
Code:
private static readonly bool m_DetectClientRequirement = true;
to false
Code:
private static readonly bool m_DetectClientRequirement = false;
and save it. Now, when booting the server, you wont have that annoying "restricted" message everyone loves so much. :D

I did this and it got rid of the message. Thank you.
[doublepost=1472699495][/doublepost]Anyone have any other ideas. Still have house issue
 

Milva

Administrator
Moderator
Did you get a new game client so it could be patched up higher?
dmuprhy stated to go into your config folder set the client path there --Config/DataPath.cfg
 

dmurphy

Administrator
ServUO Developer
No I didn't. Thought that had to be there. Will remove when I get home and try that. Thank you.

That depends on where you edited. If you edited the cs file then the @ is required in there as it turns a string into a string literal. If you remove it the server won't compile as you will have a bunch of slashes that are not escaped.

The @ in the config files means it will use the default value, it should be removed in there if you edit it.

My suggestion is to revert your datapath.cs file and use the config files.
 

Mukyluk

Citizen
That depends on where you edited. If you edited the cs file then the @ is required in there as it turns a string into a string literal. If you remove it the server won't compile as you will have a bunch of slashes that are not escaped.

The @ in the config files means it will use the default value, it should be removed in there if you edit it.

My suggestion is to revert your datapath.cs file and use the config files.

Ok, I reverted the datapath.cs file back to stock per say and got rid of the @ in the config file with the rest of it pointing to my client. Still having same problem with the houses. What am I doing wrong?
 

Milva

Administrator
Moderator
I haven't heard if you did get another client which you could patch up :) I gave a link for one
 

Milva

Administrator
Moderator
Go into that gamed folder/client look for the UO Emblem which says Client-double click this to open and allow it to patch up-this is from the link which I posted for you?