mcube520

Citizen
Greetings :

I have an error log as follow , how can I fix it ? many thanks .

RunUO Version 0.5.8269, Build 14047
.NET Framework: 4.0.30319.42000

Error:
Error deserializing particular attachments.

Specific Attachment Errors:
Server.Engines.XmlSpawner2.LevelEquipXML - Missing a serial constructor?
Server.Engines.XmlSpawner2.XmlData - Missing a serial constructor?
Server.Engines.XmlSpawner2.XMLPlayerLevelAtt - Missing a serial constructor?
Server.Engines.XmlSpawner2.XmlDialog - Missing a serial constructor?
Server.Engines.XmlSpawner2.ToolbarInfo - Missing a serial constructor?
 

Iomega0318

Vita-Nex Sponsor
We need a lot more information if we're going to help you.
To start..
What version of ServUO are you on?
What did you add or remove or do to get to this error?
 
OP

mcube520

Citizen
ServUO - [ServUO - Ultima Online Emulation] Version 0.5, Build 8269.14047 - Build on 2022/8/22 AM 07:48:14 UTC - Release
Core: Optimizing for 20 64-bit processors
Core: Compiled for .NET MONO/CSC/Unknown
RandomImpl: CSPRandom (Software)
Core: Loading config...
Scripts: Compiling C# scripts...done (cached)
Scripts: Verifying...
Finished (7451 items, 1490 mobiles, 5 customs) (0.58 seconds)
Searching for Ultima Online installations...
Found 1 Ultima Online installations:
D:\Electronic Arts\Ultima Online Classic
DataPath: D:\Electronic Arts\Ultima Online Classic
[VitaNexCore]: [UOFont]: Preloaded (Unicode, 0, 65536)
[VitaNexCore]: [UOFont]: Preloaded (Unicode, 1, 65536)

**** VITA-NEX: CORE 5.2.0.0 **** Root Directory: .\Scripts\VitaNex\Core\ Working Directory: .\VitaNexCore\ http://core.vita-nex.com
[VitaNexCore]:
[VitaNexCore]: Compile action started...
[VitaNexCore]: Compiling Services...
[VitaNexCore]: Compiling Modules...
[VitaNexCore]: Compile action completed in 0.00 seconds
[VitaNexCore]:
[VitaNexCore]: Configure action started...
[VitaNexCore]: Configuring Services...
[VitaNexCore]: Configuring Modules...
[VitaNexCore]: Configure action completed in 0.34 seconds
Regions: Loading...done
World: Loading...

Error deserializing attachments Server.Engines.XmlSpawner2.LevelEquipXML.
Missing a serial constructor?


Error deserializing attachments Server.Engines.XmlSpawner2.XmlData.
Missing a serial constructor?


Error deserializing attachments Server.Engines.XmlSpawner2.XMLPlayerLevelAtt.
Missing a serial constructor?


Error deserializing attachments Server.Engines.XmlSpawner2.XmlDialog.
Missing a serial constructor?


Error deserializing attachments Server.Engines.XmlSpawner2.ToolbarInfo.
Missing a serial constructor?


LevelSystemExtAtt Attachment Error:
Error deserializing particular attachments.
Generating report...done
Loading Ultima Live map changes
...done (215013 items, 40752 mobiles, 1 customs) (2.72 seconds)
Restricting classic client version to 7.0.97.25. Action to be taken: LenientKick
Restricting enhanced client version to 67.0.59.0 SA. Action to be taken: Kick
ServerList: Auto-detecting public IP address...
ServerList: >>> services.servuo.com
ServerList: >>> api.ipify.org
ServerList: <<< 220.135.142.52
ServerList: Done: '220.135.142.52'
Xanthos.Utilities.ConfigParser attempting to load Data/SpellCraftConfig.xml...
Xanthos.Utilities.ConfigParser failed.
[Honesty]: Generating...
[Honesty]: Generation completed in 0.00 seconds.
Xanthos.Utilities.ConfigParser attempting to load Data/JailConfig.xml...
Xanthos.Utilities.ConfigParser failed.
Xanthos.Utilities.ConfigParser attempting to load Data/ShrinkConfig.xml...
Xanthos.Utilities.ConfigParser failed.
11:19:05 Joeku's Staff Runebook: Loading...
11:19:05 VitaNexCore]:
11:19:05 VitaNexCore]: Load action started...
11:19:05 VitaNexCore]: Loading Services...
11:19:05 VitaNexCore]: Loading Modules...
11:19:05 VitaNexCore]: Load action completed in 0.09 seconds
11:19:05 VitaNexCore]:
11:19:05 VitaNexCore]: Invoke action started...
11:19:05 VitaNexCore]: Invoking Services...
11:19:05 VitaNexCore]: Invoking Modules...
11:19:05 VitaNexCore]: System.Reflection.TargetException: ??????????
? System.Reflection.RuntimeMethodInfo.CheckConsistency(Object target)
? System.Reflection.RuntimeMethodInfo.InvokeArgumentsCheck(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
? System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
? VitaNex.VitaNexCore.TryCatch(Delegate action, Action`1 handler)
11:19:05 VitaNexCore]: System.Reflection.TargetException: ??????????
? System.Reflection.RuntimeMethodInfo.CheckConsistency(Object target)
? System.Reflection.RuntimeMethodInfo.InvokeArgumentsCheck(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
? System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
? VitaNex.VitaNexCore.TryCatch(Delegate action, Action`1 handler)
11:19:05 VitaNexCore]: Invoke action completed in 0.03 seconds
 

Iomega0318

Vita-Nex Sponsor
Are you using Pub 57, 57.x, 58?
Did you just drop the xml system in your customs folder, or was it preinstalled?
Where did you download the server and xml system?
Have you had issues before?
Did you update or install something new?
 
OP

mcube520

Citizen
It's Pub 57 ,
and yes , I put Level3System-master5 in customer folder .
This server is down from ServeUO resource named "ServUO57 owltr fs ats vitanex" .
Before I add more secipts in customer folder , the origine one works good .
I'm try to add all new scripts that can work on .

thanks.