Need help getting started

HalfMercy2

Citizen
Oct 21, 2018
12
0
1
34
I used to have a running server but I haven't been able to work on anything in a year and a half to two years. It seems like I've forgotten quite a bit, including just how to get started. I downloaded and patched the client from uo.com, downloaded the zip from ServUO here and extracted to C:\ServUO-master, then ran compile.win - Release.bat and got this error:

Scripts: Verifying...
Finished (5523 items, 1325 mobiles, 3 customs) (1.32 seconds)
Config: Warning, using default value for DataPath.CustomPath
DataPath: C:\Program Files (x86)\Electronic Arts\Ultima Online Classic\
Regions: Loading...done
World: Loading...
...done (0 items, 0 mobiles, 0 customs) (0.06 seconds)
tiledata.mul was not found
Make sure your Scripts/Misc/DataPath.cs is properly configured
After pressing return an exception will be thrown and the server will terminate
Error:
System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.TypeInitializationException: The type initializer for 'Server.TileData' threw an exception. ---> System.Exception: TileData: not found
at Server.TileData..cctor()
--- End of inner exception stack trace ---
at Server.TileData.get_ItemTable()
at Server.Item.get_ItemData()
at Server.Item.UpdateLight()
at Server.Engines.Plants.MaginciaPlantSystem..ctor()
at Server.Engines.Plants.MaginciaPlantSystem.Initialize()
--- End of inner exception stack trace ---
at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor)
at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments)
at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
at Server.ScriptCompiler.Invoke(String method)
at Server.Core.Main(String[] args)
This exception is fatal, press return to exit

What have I done wrong? Or not done right?
 

PyrO

Moderator
Jan 27, 2015
1,352
195
63
you didnt point the DataPath.cfg in the Config folder to a valid classic client installation, or you did and its int the C drive path as shown, then you may need to run it with admin rights. Also make sure that you arent running the game from that folder already as it may lock the files
 
  • Love
Reactions: Allestaria

HalfMercy2

Citizen
Oct 21, 2018
12
0
1
34
Apparently I had to run the original client and let it patch a third time :) Thanks!
 
Last edited: