Running Ubuntu 20.04

john burns

Citizen
Getting these two errors.
/usr/share/dotnet/sdk/3.1.406/Microsoft.Common.CurrentVersion.targets(1177,5): error MSB3644: The reference assemblies for .NETFramework,Version=v4.8 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks [/root/ServUO/Application/ServUO.csproj]
/usr/share/dotnet/sdk/3.1.406/Microsoft.Common.CurrentVersion.targets(1177,5): error MSB3644: The reference assemblies for .NETFramework,Version=v4.8 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks [/root/ServUO/Server/Server.csproj]


But when I check to see what version I have, I get this:
dotnet version 3.1.406

What did I not install right?
What do I still need to install?

thx.
 

john burns

Citizen
How do I find out if its installed? I thought I did.
Post automatically merged:

Better yet, how do I do that?
 
Last edited:

Max

Citizen
on the CLI/terminal try 'mono --version'.
This should return something like 6.6.0 or better to have framework 4.8.
see Mono 6.6.0 Release Notes | Mono
if it is version 4.x.x you probable need to get through something like:
(see Ubuntu – Package Search Results -- mono-complete)
 

john burns

Citizen
Versions
dotnet -- 5.0.103
mono -- Mono JIT compiler version 6.12.0.107


Compiles, Starts, but after a minute the window that I am running the server in, tmux, becomes unresponsive.
I have tried using screen, but with the same results.
 
Last edited: