Resource icon

The Completely Customizable Vendor - .NET 4.0 and Cleaned Up 2014-12-25

No permission to download

Tresdni

Well-Known Member
Mar 10, 2013
93
37
35

Michele

Well-Known Member
Aug 22, 2017
79
0
39
Hi sorry for up this old 3d... i try this script i thinks i very usefull but have the same problem.

With this release it say:

JEVELRY ------- "the current display is invalid".
Classic ----------- crash

If i use Fargariel script:

Classic --------- crash

JEWELRY ------ Still run but when pg buy items the item appear locked in the backpack and its impossibile to move it.


Someone can fix? Ty all!
 

manwitch

Well-Known Member
Jul 13, 2017
180
12
54
I get this error
CS 1729: Line 2816 'Server.ContextMenus.OpenBankEntry' does not contain a constructor that takes 2 arguments
Any idea how to fix or get this script working?

I have always liked the way this vendor stone works with being able to chose the currency and whatnot.

Or If any one knows of a different script that acts similar?

Thanks in advance for any help.

ETA- So I just removed the ", this" from line 2816 and it seems to work now.
so from this
list.Add(new OpenBankEntry(@from, this));
to this
list.Add(new OpenBankEntry(@from));
 
Last edited:

Greystar

Well-Known Member
Feb 20, 2014
68
3
45
IL, US
Shard Name
Shadow Realm
I have a big problem reading the text on the "parchment" looking background can you point me to where I need to change either the text color or the background so I can read it. Only applies to when adding an Item to the vendor to be sold.
 

manwitch

Well-Known Member
Jul 13, 2017
180
12
54
I have the same thing going on. I am usually on the enhanced client though so things might be different. there are so many places in the script that reference the gumps that I don't know where to start to fix this. But maybe some one else will see this and throw in a helping hand.
On enhanced, if you "highlight" the input text boxes they show up better.
 

Greystar

Well-Known Member
Feb 20, 2014
68
3
45
IL, US
Shard Name
Shadow Realm
I have the same thing going on. I am usually on the enhanced client though so things might be different. there are so many places in the script that reference the gumps that I don't know where to start to fix this. But maybe some one else will see this and throw in a helping hand.
On enhanced, if you "highlight" the input text boxes they show up better.
I'm also using the Enhanced client for the most part and don't want to change to the Classic client just to add things to a vendor.