Peoharen

Citizen
Hey all, sorry for the vanish there for a bit. A lot's happened. New comp, new boss, family member died, life hits hard and fast what can I say. Anyway, today I wanted to do a special shout out to the people running things.
.
Recently I decided to try Final Fantasy XI. I've always wanted to play it just to run around as a Blue Mage. Well someone hooked me up, full client already configured to log into a private server. And well, FFXI is a nightmare of a game. Specially when I learned that they play on like expansion 1 which is the grindyest of grindfests. So I was like meh, I'll just boot my own server and run x20 to the XP gain right? Well, things did not go as planned.
.
Step 1. Found a server's git. Skipped grabbing git and just downloaded the files.
Step 2. I had to download some database program, grab it and run it.
Step 3. Download Python.
Step 3a. I already have Python, but it's not working. It's in AppData not Program Files.
Step 3b. Uninstall Python, download installer, install for all users.
Step 3c. Missed a click box, uninstall Python, install for all users and some other dumb click box.
Step 3d. Tell Python to update pip's wheel. I have no idea what that even means. But it shoved the update into AppData.
Step 3e. Cannot run the pip, something about this mysterious "PATH" not being correct. Google how to fix that, omg hell no.
Step 3f. Uninstall Python, refuse to update pip.
Step 4. Open cmd as admin because as I put it else where, "elitist teenagers running Unix demand people use a 23 year old depreciated method on Windows".
Step 4a. Run Python pip update on the server's files. Show how it worked!
Step 5. Configure server.
Step 6. Launch server's database.
Step 6a. Command refuses to run, files must be in git format (not exported).
Step 7. Download git.
Step 7a. Using commands, as told to me by the configure, I attempt to clone the repository. It dumps into the wrong location so I move it.
Step 7b. It's broken, download the git a 3rd freaking time.
Step 8. Database happens to work.
Step 9. Now you need express to compile the server, downloaded express for C++ and compiled.
Step 10. Ok, client time. Spend most of the day downloading another 6gb from a 3rd party website.
Step 11. Download a program that's supposed to inject loading information (think Razor).
Step 11a. Doesn't work, get told I need another program.
Step 12. Grab another program's repository.
Step 13. Open it in express, it says it's outdated but I'm like lol nope not coding updates just run as is.
Step 13a. Express cannot compile until I download more SDKs.
Step 13b. I have no idea where the update button is.
Step 13c. Delete, regrab the repository, this time I hit update.
Step 13d. Debug compiled, release refused (wtf?). Whatever, grabbed debug.
Step 13e. How do I use debug? Their Discord is inactive since 2017.
Step 14. Discord listing dozens of servers tells me I never needed that program anyway.
Step 15. Go back to FFXI's Razor thing and personalized help configuring it.
Step 16. Account creation success, server registers the hit. Windows Firewall pops up and asks if I want to allow it. Hecks yeah!
Step 17. Windows loading bar of doom, socket remains closed, windows refuses to help, retrying results in loading crashes.
Step 18. Helpful Discord says reinstall and repatch that 6gb client is the only way to fix.
tl;dr: You need a combination of Client, Direct X, Bootloader, LUA support, Server, Git, Express, various SDKs, Python, custom py pips, and MariaDB from like 12 different dependents just to progress to the point of "it's still not working".
.
Comparatively, if you want to get into Ultimate Online emulation you need.
Step 1. Official client from any of the official sources, no 3rd party needed.
Step 2. Come here and grab the exported version of the git, no repository program needed.
Step 2a. Configure server (mostly just say where client is) then click on the bat file to compile, no express needed.
Step 2b. If you're not using windows update, grab a .NET version that works, no other repositories needed.
Step 3. Come here and grab the client injector and just tell it the IP, no other repositories needed.
Step 4. Play the game, no database program needed, no installing runtimes a dozen times in the incorrect way, no custom updates to them, nothing. It just works, and if it doesn't, the forum appears to have people active in trying to help and the Discord has a few people trying to as well.
.
Give your selves a hand for being awesome. You guys have no idea how "easy" it is to run a UO server compare to other MMOS that are out there.
And thanks for being great.
.
.
.
Oh Hey I forgot this Xenforo thing was a total crapshoot. Everything past this is a second post discussing my experience in FFXI so far. And don't mind the extra dots, the forum keeps wiping new lines if they are empty for some reason and I forgot how to create a paragraph here.
.
.
.
Also my crash course into FFXI has been something else entirely.
.
So there is like no menus for this game. You can soft target using tab but then you have to hit enter to open a small menu that lists commands FF style. Like picking attack causes instant aggro as you draw your weapon. Otherwise you can click on Spells, pick one, retarget the monster, cast delay, and then retarget again, and hit attack. Otherwise after casting you just stand there dying. Also you need to use WASD to constantly move around or your character gets locked into not being able to see monsters punching you to death.
.
The game as it turns out is meant to be played via macro spam. You get like 20 macros per "book" and idk 20ish books. So like I have a macro called "Bow", it runs a system command of something like "/ra <t>" and I have to use this macro after using the attack command to even draw and fire a bow over the next 8 seconds and respawn it every single time. Casting is just as insane, My macro for stone is "/attack <wait 2>" + "ma stone <t>", because it takes two seconds to draw your weapon and you want it out before triggering aggro. This command cannot be used twice in a row since sending attack again puts your weapon away, so I have a macro to start fighting and a macro to use while fighting.
.
Over like 6 hours of play I've made it to lv5. I can kill exactly two types of monsters. Rabbits (40xp) and these ground worms (20xp). Trying to kill these bats near them instantly kills me and someone already supersized my sword (worth about 3,000gil, you start with 50 and I've made <100 so far). I need like 1,200xp to level up, but each death wipes like 400xp. Yeah, let me repeat. Each death wipes xp. Not only that, the only healing method I have is basically bow down and pray for 2 minutes of real life time. So every two fights I need to take a time out. With every death I'm sent back needing ten more flawless kills.
.
Now newer servers don't have XP loss until lv30. But holy crap. Games are supposed to use low levels to introduce mechanics and advertise how great they can be to keep you hooked. I've spent 6hrs grinding and basically the only thing I've unlocked is a two hit attack, that requires a thousand "TP" points and each time I rest I lose 800 of them or more. People in the game had to show me how to even do stuff as basic as attack and cast, or even heal, because absolutely none of that is explained to you. Heck, pushing - to see the main menu? Why not escape? Spacebar? Something? *sigh* Worst part is first time I logged in I got menu locked. After closing the client I got to learn the lesson that you cannot log back in for ten minutes after leaving. Who even designs a game to do that?.
.
.
Update: Today I got the client reinstalled and figured I'd try again. Well I happened to uninstall a custom server's client. And it doesn't uninstall it's files, it just deletes everything in it's root folder. Which happened to have everything moved into it because it shoved it's self as C:<Name>\FFXI and I just been shoving everything in <Name>. Server's gone, client injector is gone, the installs to everything but the client, gone and gone and gone. *sigh*
 
Last edited: