UO Black Box - Open Beta

UO Black Box - Open Beta 1.0.0.58

No permission to download

GoldDraco13

Squire
Aug 1, 2014
329
217
43
48
Canada
mycy4.com
Donate
Donate money to this user
If you are using runuo, you can go into the scripts for the server and edit the strings, I used the latest NetFrameworks, which has additional ways to code strings. If you do not know how to convert them, then you'll need to wait till I finish the release, I don't plan on updating this Beta!

Code:
string convertString = $"#:{dirname}:";

Change to

string convertString = "#:" + dirname + ":";
 

Diesel

Gold Donator
Sep 7, 2014
160
36
28
55
Shard Name
Medival World 73.146.176.79
So I updated the string in line 271 of the BlackBoxSaveBuild.cs then reran the server compile and got this.


Errors:
+ UOBlackBox/BBControlBox.cs:
CS1026: Line 32: ) expected
CS1002: Line 32: ; expected
CS1525: Line 32: Invalid expression term ')'
CS1002: Line 32: ; expected
CS1525: Line 32: Invalid expression term ')'
CS1525: Line 36: Invalid expression term 'else'
CS1002: Line 36: ; expected
+ UOBlackBox/BlackBoxCleanUp.cs:
CS0117: Line 53: 'Server.Utility' does not contain a definition for 'WriteConsoleColor'
CS0117: Line 60: 'Server.Utility' does not contain a definition for 'WriteConsoleColor'
CS0117: Line 64: 'Server.Utility' does not contain a definition for 'WriteConsoleColor'
Scripts: One or more scripts failed to compile or no script files were found.

I know you are working on a full release and just wanted to give this to you in case it can help head off any problems GoldDraco.


------------------------------------------------------------------------------------------------------------------------
ServUO - [https://www.servuo.com] Version 0.5, Build 6349.40628
Core: Optimizing for 12 64-bit processors
RandomImpl: CSPRandom (Software)
Core: Loading config...
Scripts: Compiling C# scripts...Failed with: 2 errors, 40 warnings
 

dmt

Citizen
Apr 18, 2020
1
0
1
Followed installation steps, but when I try to add anything, the target does not appear in the client
 

Diesel

Gold Donator
Sep 7, 2014
160
36
28
55
Shard Name
Medival World 73.146.176.79
Preciate that GoldDraco. I have a ton of work in my older pub, and pandora is a pain to run.
 

Psych0

Citizen
Apr 11, 2020
11
3
3
hi, it looks like a really nice job but i have trouble using it with my remote server. can I have some detailed installation instructions?

I'm sure it will help the whole community

thank you :)
 

GoldDraco13

Squire
Aug 1, 2014
329
217
43
48
Canada
mycy4.com
Donate
Donate money to this user
hi, it looks like a really nice job but i have trouble using it with my remote server. can I have some detailed installation instructions?

I'm sure it will help the whole community

thank you :)
Remote Service works by having the tool talk to its own server which runs on the same machine that runs Servuo!

For remote service, go to settings, download the remote server and enter in the tcp/port of your server

Upload the uoblackbox server to your server and run it, when it starts you enter in port and it is ready to go.

Restart tool and it should have a start up message that it started remotely

Now use tool as normal, make sure you turn on control box in game before sending commands!

I hope those help, I will have more detailed help messages in the official release!
 

Psych0

Citizen
Apr 11, 2020
11
3
3
Remote Service works by having the tool talk to its own server which runs on the same machine that runs Servuo!

For remote service, go to settings, download the remote server and enter in the tcp/port of your server

Upload the uoblackbox server to your server and run it, when it starts you enter in port and it is ready to go.

Restart tool and it should have a start up message that it started remotely

Now use tool as normal, make sure you turn on control box in game before sending commands!

I hope those help, I will have more detailed help messages in the official release!

really strange. it's like I did before, now I have done all the steps exactly as you told me and I still have communication problems when I try to decorate for example.

with the server I have no communication problems, I can easily reach it with a ping or if I make a telnet on the server port it answers me without problems
 

GoldDraco13

Squire
Aug 1, 2014
329
217
43
48
Canada
mycy4.com
Donate
Donate money to this user
I'm not sure what your doing wrong, more details of what you have done are needed to help!

I'll admit this was not a easy set up and I am changing the way this works for the official release!
Post automatically merged:

Also I never did mention that you still need to do the other set up stuff like moving the scripts the tool creates to the servuo server, I have the scripts auto load locally but on a remote server you need to manually upload them, as with the box folders!
 
Last edited:

Psych0

Citizen
Apr 11, 2020
11
3
3
I installed on the BlackBox server and it works wonderfully if I use it locally on the server. since via RDP it is a bit difficult to use UO to decorate for example I decided to install BlackBox on my client pc, I configured blackbox in the same way as I configured it on the server. I downloaded the remote server and copied it to the server (separate from the previous blackbox configuration). on the client I configured the remote server and turned on the server, restarted the client side tool and tried to decorate but it gives me connection problems.
I also tried on the server to make a backup of the BB folder and copy the server files into it and thus launch the server but without results.

the connection between client and server takes place without any problems.
 

GoldDraco13

Squire
Aug 1, 2014
329
217
43
48
Canada
mycy4.com
Donate
Donate money to this user
To be honest, I am having a hard time visualizing your issue, I've also changed the way I am doing the connection to the server for the official release and have spent 0 time improving the beta remote service! So I would either go back to using it locally and wait for the release or try to isolate the issue so I can help with a minor patch if needed!
 

Psych0

Citizen
Apr 11, 2020
11
3
3
if in the official release it works differently I would say to ignore this problem. I can wait for the official version :)
 
  • Like
Reactions: GoldDraco13

Sygun

Citizen
May 12, 2020
9
1
3
I'm having issues getting this to run, everything is installed and set up but commands never seem to be passed to the server/client.

I'm running the server, blackbox and the game client all locally on my PC from the same drive.
I've downloaded the asset folder, pointed black box to it and pointed it to the scripts folder in the server folder.
Name matches my character name
Character is Owner Rank.

Really at a loss as to what to try next, I mean I could set up the remote client even though I'm running locally.
 

Diesel

Gold Donator
Sep 7, 2014
160
36
28
55
Shard Name
Medival World 73.146.176.79
For it to work on your GM character you have to [add BBControlBox then put that cube into your backpack. Then you must click it to turn it on. Once you do that everything should work. Make sure when you launch UOBlackbox that it is passing the boot up steps saying verified after each step.

The cube will turn from dark black to I think white indicating it's working and you will see a message about a watcher file or something.

Hope that works for you.
 

Sygun

Citizen
May 12, 2020
9
1
3
For it to work on your GM character you have to [add BBControlBox then put that cube into your backpack. Then you must click it to turn it on. Once you do that everything should work. Make sure when you launch UOBlackbox that it is passing the boot up steps saying verified after each step.

The cube will turn from dark black to I think white indicating it's working and you will see a message about a watcher file or something.

Hope that works for you.
Thanks for the quick update, got the cube spawning, when i double click it in my bag to turn it on it attempts to start a new instance of the server, closing the original one. Obviously the client disconnects. It's unable to start the new server instance because the client is open still
 

Diesel

Gold Donator
Sep 7, 2014
160
36
28
55
Shard Name
Medival World 73.146.176.79
What version of ServUO pub are you using? I had a server that was Pub 54 and it wouldn't run on it. I think Draco is looking at that as he prepares a release. This is a beta version. I had to upgrade to the new current ServUO Pub for it to work. I was under the impression GoldDraco was going to try to get it to work with older versions but... that is a pretty tall order. I would try downloading the current Pub and running it stock first to see if that works. Then go from there. If you're on the current pub then I'm out of ideas other than the looking at the line 271 fix if that seems to mirror your problems. That fix is listed along with a couple of others earlier in this thread. If you are using RunUO then there is also a fix for that listed earlier but RunUO is pretty long in the tooth nowadays. That's about all I got to counsel you with. Sorry 8(