UO Black Box - Open Beta

UO Black Box - Open Beta 1.0.0.103

No permission to download

Sygun

Citizen
May 12, 2020
10
3
3
Yeah I'm using the latest servuo - fresh server set up earlier this week. I'll have a look for the line 271 fix and see if that helps. Thanks trying, I'm sure I'll get it working...just very odd that it tries to invoke a new server
Post automatically merged:

Fixed it! Went to check the script for the control box itself. In the script it had links to the old location black box was installed to - deleted all the scripts for Blackbox, reset and installed it again...now works a treat!
 
Last edited:

GoldDraco13

Squire
Aug 1, 2014
493
316
63
48
Canada
mycy4.com
Donate
Donate money to this user
I made a few Ninja Fixes to the Beta last night, Version 1.0.0.102 should address the line 271 in the control box and the clean up, this will allow the box to be used on recent older versions of ServUO, still working on older versions of servuo and runuo!
 

Diesel

Gold Donator
Sep 7, 2014
177
28
28
55
Shard Name
Medival World 73.146.176.79
Been playing with Beta update you pushed today GoldDraco13 and it has been working for a couple of hours as I deco without any problems on a ServUO Pub 54.
 
  • Like
Reactions: GoldDraco13

zerodowned

Moderator
ServUO Developer
Jun 28, 2014
1,828
271
83
*This is a click once install program, so it depends on your security if you get warnings or not, I am a trusted registered developer with a valid signed cert attached to the program.

*The Program is only 25MB at this version! the Art Zip is just above 100MB, and unzips to 600+MBs

So with that said, the program will install like any other, with a location in the start menu, plus it is put into control panel for easy removal!

The separate zip that needs to be downloaded is just a zip with jpg/png and bmp UO Art, I designed the tool to use these instead of messing with the actual mul/uop files, easier to update and added control and flexibility down the road!

The Zip also has a folder set up to handle files that the tool writes and reads, plus will hold the save location for saved and exported gumps come next release!

This download can be put anywhere within the access of both server and tool, meaning on same drive!

if the art is just for display within the program why not convert all the PNG and BMP files to JPG? That should reduce the size significantly

Also is there a way to prevent auto updates? Does it only check for updates when you run the program?
 

GoldDraco13

Squire
Aug 1, 2014
493
316
63
48
Canada
mycy4.com
Donate
Donate money to this user
I have reworked the program and the pictures will not be a issue in the official release but I agree with you, I would rework the images!

The program looks for a mandatory update on launch, I control this on my end if the update is required or optional, the last few were set to required so they were needed and the program will update on its own at launch. You have a option to take optional updates which to date have been only a few that I sent out in between required ones but were mute to the most recent update which was a required one!

In the official release, you'll have the option to turn on/off updates!
 

Diesel

Gold Donator
Sep 7, 2014
177
28
28
55
Shard Name
Medival World 73.146.176.79
Anyone using this great program should remember to support developers like this with whatever they can. Via the donation page. As a dog owner sorry for your loss GoldDraco13. Dogs are family members in all regards.
 

GoldDraco13

Squire
Aug 1, 2014
493
316
63
48
Canada
mycy4.com
Donate
Donate money to this user
This Beta version was built using servuo 56, the release will be tested for the latest servuo, it should be out in a few weeks, I'm still in the process of finishing some tools and refining code!

*Plus I have been working on another system that will be releasing this weekend!
 
  • Like
Reactions: LordFenris

Diesel

Gold Donator
Sep 7, 2014
177
28
28
55
Shard Name
Medival World 73.146.176.79
Getting crashes when using the map tool, Pub 56 server, and .102 version of Blackbox. I will delete the program and reinstall tomorrow to see if it helps.
 

Diesel

Gold Donator
Sep 7, 2014
177
28
28
55
Shard Name
Medival World 73.146.176.79
So I went ahead and uninstalled UOBlackbox and deleted the old files then reinstalled it. Whenever I log on with my admin character I go to use the map tool to move around the world. When I click somewhere to move to that point in the world I get an instant crash of the server and reboot. No errors or warnings. I know a couple of weeks ago I was using the tool to move around just fine not sure what has changed. I tried a couple of different maps the crash happens on both of them.
I would be interested to see if it happens on a fresh unmodified server but to my thinking, it should be somewhere in the Blackbox scripts?

Here is the relevant command log when it crashed. Each time I did set map property via the map tool:(X'x represent the account name that I hid)

6/16/2020 9:08:41 PM: 127.0.0.1: Owner 0x76 "Presto" ('XXXXX') set property 'map' of 0x76 "Presto" ('XXXXXX') to 'Ilshenar'
6/16/2020 9:08:41 PM: 127.0.0.1: Owner 0x76 "Presto" ('XXXXX') set property 'x' of 0x76 "Presto" (XXXXX') to '35'
6/16/2020 9:08:41 PM: 127.0.0.1: Owner 0x76 "Presto" ('XXXXX') set property 'y' of 0x76 "Presto" ('XXXXX') to '1020'
6/16/2020 9:08:41 PM: 127.0.0.1: Owner 0x76 "Presto" ('XXXXX') set property 'z' of 0x76 "Presto" ('XXXXX') to '-25'
6/16/2020 9:08:41 PM: 127.0.0.1: Owner 0x76 "Presto" ('XXXXXX') used command 'self set map Ilshenar x 35 y 1020 z -25'
6/16/2020 9:11:27 PM: 127.0.0.1: Owner 0x76 "Presto" ('XXXXX') set property 'map' of 0x76 "Presto" ('XXXXX') to 'Ilshenar'
6/16/2020 9:11:27 PM: 127.0.0.1: Owner 0x76 "Presto" ('XXXXXX') set property 'x' of 0x76 "Presto" (XXXXXX') to '130'
6/16/2020 9:11:27 PM: 127.0.0.1: Owner 0x76 "Presto" ('XXXXXX') set property 'y' of 0x76 "Presto" ('XXXXXX) to '110'
6/16/2020 9:11:27 PM: 127.0.0.1: Owner 0x76 "Presto" ('XXXXXXXXXX') set property 'z' of 0x76 "Presto" ('XXXXXXt') to '-27'
6/16/2020 9:11:27 PM: 127.0.0.1: Owner 0x76 "Presto" ('XXXX') used command 'self set map Ilshenar x 130 y 110 z -27'
6/16/2020 9:12:35 PM: 127.0.0.1: Owner 0x76 "Presto" ('XXXXXX') set property 'map' of 0x76 "Presto" ('XXXXX') to 'Trammel'
6/16/2020 9:12:35 PM: 127.0.0.1: Owner 0x76 "Presto" ('XXXXXX') set property 'x' of 0x76 "Presto" ('XXXXX') to '4100'
6/16/2020 9:12:35 PM: 127.0.0.1: Owner 0x76 "Presto" ('XXXXX') set property 'y' of 0x76 "Presto" ('XXXXXX') to '3340'
6/16/2020 9:12:35 PM: 127.0.0.1: Owner 0x76 "Presto" ('XXXX') set property 'z' of 0x76 "Presto" ('XXXXXX') to '12'
6/16/2020 9:12:35 PM: 127.0.0.1: Owner 0x76 "Presto" ('XXXXX') used command 'self set map Trammel x 4100 y 3340 z 12'

Crash Log


Server Crash Report
===================

ServUO Version 0.5, Build 7427.38276
Operating System: Microsoft Windows NT 6.2.9200.0
.NET Framework: 4.0.30319.42000
Time: 6/16/2020 10:37:14 PM
Mobiles: 43323
Items: 230144
Exception:
System.NullReferenceException: Object reference not set to an instance of an object.
at Server.Item.ProcessDeltaQueue()
at Server.Core.Main(String[] args)
 
Last edited:

GoldDraco13

Squire
Aug 1, 2014
493
316
63
48
Canada
mycy4.com
Donate
Donate money to this user
I should have said this before, but there is no need to delete the tool, if something is messed up, the best thing is to go to settings tab and use the Reset Tool feature. Any other problems will need to be done on my end and sent out on a patch!

Back to the problem, I just want to isolate this as nothing is jumping out at me and my test works fine on distro!

Are you using custom maps?

What teleport were you using? Normal, Gate or special?
 

Diesel

Gold Donator
Sep 7, 2014
177
28
28
55
Shard Name
Medival World 73.146.176.79
So as a very very old once upon a time tech support guy there is a generic list of things to do when encountering problems that I failed to do. One of them was to uninstall and reinstall the software. But way before that should have been turn your computer off let it set for 30 secs then reboot it and retry. An update to another program made me restart the computer and now all is working just fine. Not happy I became "that guy" sorry for any alarm. But ya it's golden now.
 
  • Like
Reactions: GoldDraco13

GoldDraco13

Squire
Aug 1, 2014
493
316
63
48
Canada
mycy4.com
Donate
Donate money to this user
No worries, I come from those days too, reset power, reinstall program etc etc

Plus as I am working on the official release of UOBlackbox, I am eager to hear feedback/issues, so let me know if anything bugs out or if you have any suggestions to make UOBB better!
 
  • Like
  • Love
Reactions: Espcevan and Diesel

GoldDraco13

Squire
Aug 1, 2014
493
316
63
48
Canada
mycy4.com
Donate
Donate money to this user
News : Update

I just wanted to let everyone know that is using this project, that it is still being worked on. In fact I have been spending this time working on my skills so I can take the box to the level I would like it to be.

This beta was a great starting point and gave me the outline for what needs to be done. I had left areas of the code where I did not know at the time what to do to accomplish what I wanted and instead made a few workarounds which work but not as good as if I did it the way I wanted to!

Needless to say, with the advancements I have made this year in my knowledge of c#, has now allowed me to bring a more responsive and powerful tool to you all. I am about a week out from releasing the first official out of beta version of this tool, today I've been working on the black box server, which will now communicate directly to the emulator and the tool, I am removing the file watcher which was one of my workarounds!

Anyways, just thought I'd share as I did my test today and applied my new knowledge and things work beautifully, I borrowed a quote from Karate Kid to mark the success!

Untitled.jpg

*The Official release will be version 2.0.0.0 (Keep an eye out for more updates coming soon)