SomeDude

Vita-Nex Sponsor
Fresh Pub 57 Vita-Nex getting these errors i do have .net 4.8 thx for any help

ServUO - [ServUO - Ultima Online Emulation] Version 0.5, Build 8352.19393 - Build on 11/13/2022 10:46:26 AM UTC - Release
Core: Optimizing for 16 64-bit processors
Core: Compiled for .NET MONO/CSC/Unknown
RandomImpl: CSPRandom (Software)
Core: Loading config...
Scripts: Compiling C# scripts...Failed with: 3 errors, 1 warnings
Warnings:
+ Core-5.3.0.1/SuperGumps/Framework/Base/SuperGump_Tooltips.cs:
CS0109: Line 36: The member 'SuperGump.AddTooltip(string)' does not hide an accessible member. The new keyword is not required.
Errors:
+ Core-5.3.0.1/Extensions/System/EnumExt.cs:
CS8302: Line 68: Feature 'enum generic type constraints' is not available in C# 7.1. Please use language version 7.3 or greater.
+ Core-5.3.0.1/Extensions/Server/SerializeExt.cs:
CS8302: Line 1531: Feature 'enum generic type constraints' is not available in C# 7.1. Please use language version 7.3 or greater.
CS8302: Line 1595: Feature 'enum generic type constraints' is not available in C# 7.1. Please use language version 7.3 or greater.
CS8302: Line 1613: Feature 'enum generic type constraints' is not available in C# 7.1. Please use language version 7.3 or greater.
+ Core-5.3.0.1/PropertyObjects/SettingsObject.cs:
CS8302: Line 22: Feature 'enum generic type constraints' is not available in C# 7.1. Please use language version 7.3 or greater.
Scripts: One or more scripts failed to compile or no script files were found.
- Press return to exit, or R to try again.
 

Voxpire

Vita-Nex
Administrator
Did you upgrade the project itself to target .net 4.8?
You can cross reference with the latest 57.2 release: the csproj files must be updated as well as ScriptCompiler.cs
 

SomeDude

Vita-Nex Sponsor
yes its target to 4.8 and I'm using the latest 57 and the csproj files says in on 4.8 same with script
 
Last edited: