Iomega0318

Vita-Nex Sponsor
I hadn't realized how old this was until I went to post, but anyways I added in the module and went to configure it and my client crashed, unsure if this is related to the plugin as it's never happened before. Let me know and I can report it to CUO as well. Thanks.

C#:
####################### [START LOG] ########################
ClassicUO [STANDARD_BUILD] - 0.1.10.143 - 01/24/2022 22:57:46
OS: Win32NT x64
Thread: CUO_MAIN_THREAD

Shard: playuo.live
ClientVersion: 7.0.91.15

Exception:
System.IndexOutOfRangeException: Index was outside the bounds of the array.
   at System.ThrowHelper.ThrowIndexOutOfRangeException()
   at ClassicUO.Network.Huffman.DecompressChunk(Span`1 src, Int32& srcOffset, Int32 srcLength, Span`1 dest, Int32 destOffset, Int32& destLength)
   at ClassicUO.Network.NetClient.DecompressBuffer(Span`1 buffer, Int32& length)
   at ClassicUO.Network.NetClient.ProcessRecv()
   at ClassicUO.Network.NetClient.Update()
   at ClassicUO.GameController.OnNetworkUpdate(Double totalTime, Double frameTime)
   at ClassicUO.GameController.Update(GameTime gameTime)
   at Microsoft.Xna.Framework.Game.Tick()
   at Microsoft.Xna.Framework.Game.RunLoop()
   at Microsoft.Xna.Framework.Game.Run()
   at ClassicUO.Client.Run()
   at ClassicUO.Bootstrap.Main(String[] args)
######################## [END LOG] ########################
 

Voxpire

Vita-Nex: Core
Administrator
I hadn't realized how old this was until I went to post, but anyways I added in the module and went to configure it and my client crashed, unsure if this is related to the plugin as it's never happened before. Let me know and I can report it to CUO as well. Thanks.
Please report this to ClassicUO first, the client crash report doesn't help debug the server-side module.
The gump is relatively simple compared to most others in my systems, so it's weird that it would start doing this after all these years (if it even is the gump causing it) :p
 

Iomega0318

Vita-Nex Sponsor
Please report this to ClassicUO first, the client crash report doesn't help debug the server-side module.
The gump is relatively simple compared to most others in my systems, so it's weird that it would start doing this after all these years (if it even is the gump causing it) :p
Reported, and yeah I launched UOSteam and it seems to work fine with that client. Once it's activated CUO works fine, it's when you scroll through the modules list that it throws a fit.
 

Voxpire

Vita-Nex: Core
Administrator
Reported, and yeah I launched UOSteam and it seems to work fine with that client. Once it's activated CUO works fine, it's when you scroll through the modules list that it throws a fit.
Ahh OK. That's not a module-specific issue but it's likely that CUO doesn't like something with the [VNC gump - I will have to work on its design to reduce its compressed length.