Install Mono-Complete on Ubuntu 16.04

  • Views Views: 154
  • Last updated Last updated:
  • Sometimes you need a different version of Mono for certain scripts due to compatibility.

    If you plan to use the updated MyRunUO posted on ServUO to create a webpage for your shard, you'll need version 5 over version 4 included in the distro because some functions will not allow a proper database update. To update to Mono 5, do the following...

    1. Apt-get update

    2.
    sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF

    3. sudo apt install apt-transport-https ca-certificates

    4. echo "deb https://download.mono-project.com/repo/ubuntu stable-xenial main" | sudo tee /etc/apt/sources.list.d/mono-official-stable.list

    5.sudo apt update

    6. Apt-get install mono-complete

    Mono 5.20 is compatible with the new MyRunUO on this site