Cant find servuo.sh?

StilleVande

Citizen
Apr 30, 2017
32
2
3
45
Forney, TX
www.stillevande.com
Shard Name
Ascension
Trying to compile, getting this error:

[email protected]:~/server$ make
`pwd`/ServUO.sh
/home/ultima/server/ServUO.sh: 2: /home/ultima/server/ServUO.sh: mono64: not found
Makefile:21: recipe for target 'run' failed
make: *** [run] Error 127
[email protected]:~/server$ ls /home/ultima/server/ServUO.sh
/home/ultima/server/ServUO.sh

[email protected]:~/server$ sudo aptitude install mono-complete
[sudo] password for ultima:
mono-complete is already installed at the requested version (4.8.1.0-0xamarin1)
mono-complete is already installed at the requested version (4.8.1.0-0xamarin1)
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.

[email protected]:~/server$ which mono
/usr/bin/mono


I know Im missing something small.

Ideas? :)
 

arvoreen

Rookie
Aug 20, 2014
74
1
8
Maine
Shard Name
N/A
/home/ultima/server/ServUO.sh: 2: /home/ultima/server/ServUO.sh: mono64: not found

I believe that's indicating that line 2 of ServUO.sh is attempting to call mono64, but cannot find it. Opening ServUO.sh with a text editor should be able to confirm.
 

john burns

Knight
Mar 12, 2014
745
26
28
49
Michigan, USA
vachiadroylia.dynu.net
Shard Name
Vachia Droylia
u may need to convert ServUO.sh from a windows to a linux bash script. (yes i said that.)

options #1- using notepad++
using notepad++, do this:
open servuo.sh
edit tab - EOL Conversion - click on unix/osx format
save the file
should work

options #2 - using mobaxterm
open text editor on linux (i use nano, very simple to use)
but type this line: texteditor Serv.sh (enter)
using notepad++, copy code into Serv.sh
save file
should work
 

PyrO

Paladin
Jan 27, 2015
1,294
147
63
This issue was already solved, an it had nothing to do with the line ending ;)

mono64 is a MacOS thing not linux, thats where the issue comes from
 

XeroX

Squire
Jun 8, 2016
129
8
18
This is not a compiler issue, no need to link it.

Actually we can drop this completely now.

brew distributes mono 5.4.x

mono is defaulting to 64bit since 5.2
 
Last edited: