Crash Report

Howard57

Active Member
Dec 3, 2018
36
3
58
I'm lost, tried reinstalling servuo and UO and still crashing...
''
Server Crash Report
===================
RunUO Version 0.5, Build 7116.507
Operating System: Microsoft Windows NT 6.2.9200.0
.NET Framework: 4.0.30319.42000
Time: 6/26/2019 3:31:04 PM
Mobiles: 4404
Items: 125146
Exception:
System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.TypeInitializationException: The type initializer for 'Ultima.Art' threw an exception. ---> System.UnauthorizedAccessException: Access to the path 'C:\Program Files (x86)\Electronic Arts\Ultima Online Classic\artlegacymul.uop' is denied.
at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share)
at Ultima.FileIndex..ctor(String idxFile, String mulFile, String uopFile, Int32 length, Int32 file, String uopEntryExtension, Int32 idxLength, Boolean hasExtra) in C:\OldSonomaREPACk\Ultima\FileIndex.cs:line 241
at Ultima.Art..cctor() in C:\OldSonomaREPACk\Ultima\Art.cs:line 15
--- End of inner exception stack trace ---
at Ultima.Art.Measure(Bitmap bmp, Int32& xMin, Int32& yMin, Int32& xMax, Int32& yMax)
at Server.CollectionItem..ctor(Type type, Int32 itemID, Int32 tooltip, Int32 hue, Double points, Boolean questitem)
at Server.Engines.Blackthorn.BlackthornRewards.Initialize()
--- End of inner exception stack trace ---
at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor)
at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments)
at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
at Server.ScriptCompiler.Invoke(String method) in C:\OldSonomaREPACk\Server\ScriptCompiler.cs:line 671
at Server.Core.Main(String[] args) in C:\OldSonomaREPACk\Server\Main.cs:line 547
Clients:
- Count: 0
""
 

Falkor

Well-Known Member
Apr 11, 2018
116
30
wpshard.com
Shard Name
Whispering Pines
It looks like an access issue that is a "security feature" of Windows. Instead of jumping through all the hoops required to allow programs to access those folders, just make another copy for your server to use.

Copy your client to a folder on the root of the drive, say "C:\UOclientfiles"

Then point your server's DataPath.cs to that folder, inserting the CustomPath line right after the comment block near the top.

Code:
*/
private static string CustomPath = @"C:\UOclientfiles";

private static readonly string CustomPath = Config.Get(@"DataPath.CustomPath", default(string));

static DataPath()
....
 

PyrO

Well-Known Member
Jan 27, 2015
1,152
92
Falkor, there is the DataPath.cfg. It is meant so that nobody has to touch that file for no reason
 

Falkor

Well-Known Member
Apr 11, 2018
116
30
wpshard.com
Shard Name
Whispering Pines
My apologies -- I haven't had to change my datapath in literally years. I knew it had something to do with datapath and I mis-remembered .cs for .cfg.

Perhaps the DataPath.cs comments should be changed from
Code:
        /* If you have not installed Ultima Online,
        * or wish the server to use a separate set of datafiles,
        * change the 'CustomPath' value.
        * Example:
        *  private static string CustomPath = @"C:\Program Files\Ultima Online";
        */
to reflect that the change should be made in /config/datapath.cfg so that others don't make the same assumption. I figured I had to be in the right place since the were instructions mentioning it, but you're right -- my actual custom path is set in datapath.cfg after all!
 

Howard57

Active Member
Dec 3, 2018
36
3
58
ok I followed your example on Line 5 and added this ( @"C:\Program Files\Ultima Online"; ) and it loaded so far without any problems. Now to figure out how to reinstall my account with the backup files.
Thank you
Howard57