Custom Houses

Ishya

Citizen
Hello, I am running the newest release to serveUO and I have the newest client as well! I am having an issue with my custom houses when I use the house placement tool I can place a classic house all day long but when I go to place a custom house it will place but I get no sign and no stairs. I am not able to walk in the house or teleport into the house. I am also unable to delete the house once it is placed. Can anyone help me and point me in the right direction on how to fix this!
Post automatically merged:

Client: 127.0.0.1: Entered World (0x74 "Talila")
Warning: Multi data files not found!
System.IndexOutOfRangeException: Index was outside the bounds of the array.
at Server.Multis.DesignStateDetailed.Clear(Byte[] buffer, Int32 size) in C:\Users\krazz\Desktop\Shard Needs\ServUO-master\Scripts\Multis\HouseFoundation.cs:line 2294
at Server.Multis.DesignStateDetailed..ctor(Int32 serial, Int32 revision, Boolean response, Int32 xMin, Int32 yMin, Int32 xMax, Int32 yMax, MultiTileEntry[] tiles) in C:\Users\krazz\Desktop\Shard Needs\ServUO-master\Scripts\Multis\HouseFoundation.cs:line 2327
at Server.Multis.DesignStateDetailed.CompressionThread() in C:\Users\krazz\Desktop\Shard Needs\ServUO-master\Scripts\Multis\HouseFoundation.cs:line 2581
System.IndexOutOfRangeException: Index was outside the bounds of the array.
at Server.Multis.DesignStateDetailed.Clear(Byte[] buffer, Int32 size) in C:\Users\krazz\Desktop\Shard Needs\ServUO-master\Scripts\Multis\HouseFoundation.cs:line 2294
at Server.Multis.DesignStateDetailed..ctor(Int32 serial, Int32 revision, Boolean response, Int32 xMin, Int32 yMin, Int32 xMax, Int32 yMax, MultiTileEntry[] tiles) in C:\Users\krazz\Desktop\Shard Needs\ServUO-master\Scripts\Multis\HouseFoundation.cs:line 2327
at Server.Multis.DesignStateDetailed.CompressionThread() in C:\Users\krazz\Desktop\Shard Needs\ServUO-master\Scripts\Multis\HouseFoundation.cs:line 2581
System.IndexOutOfRangeException: Index was outside the bounds of the array.
at Server.Multis.DesignStateDetailed.Clear(Byte[] buffer, Int32 size) in C:\Users\krazz\Desktop\Shard Needs\ServUO-master\Scripts\Multis\HouseFoundation.cs:line 2294
at Server.Multis.DesignStateDetailed..ctor(Int32 serial, Int32 revision, Boolean response, Int32 xMin, Int32 yMin, Int32 xMax, Int32 yMax, MultiTileEntry[] tiles) in C:\Users\krazz\Desktop\Shard Needs\ServUO-master\Scripts\Multis\HouseFoundation.cs:line 2327
at Server.Multis.DesignStateDetailed.CompressionThread() in C:\Users\krazz\Desktop\Shard Needs\ServUO-master\Scripts\Multis\HouseFoundation.cs:line 2581
etria.ddns.netetria.ddns.netetria.ddns.net
 
Last edited:

Lokai

Moderator
ServUO Developer
It sounds like your UO Client files are corrupted or something. Either that or your DataPath was not set correctly, or a config file got messed up.
 

Ishya

Citizen
GoldDraco is this the one you already gave me?
Post automatically merged:

that did not work and I tried uninstalling UO and reinstalling that did not work either
Post automatically merged:

this is not an error I get on startup it is an error I get whenever I place a house
 
Last edited:

GoldDraco13

Knight
Ya sorry about that, looks like this array is causing the issue, will do some testing later for a fix!

byte[] stairBuffer = m_StairBuffers[stairBufferIndex];
Post automatically merged:

After some testing, I could not reproduce your crash, Lokai has pointed out what I think as well, you have a corrupt UO install, go to https://uo.com/client-download/, download the classic client, fully patch it, then you should be good to go!
 
Last edited:

Ishya

Citizen
ok, I will try that tomorrow but it works fine when I am logged into some else's server it is just mine that is messing up! I will try the install in the morning :)
 

Ishya

Citizen
would it do this is I am using a client to log into my shard and another shard at the same time?
 

GoldDraco13

Knight
I would think so, I'm pretty sure there is no support for 2 clients being open at the same time on a computer. I'm sure I've seen the message pop up when I open a second one by accident.
 

Lokai

Moderator
ServUO Developer
If you have 3 copies of your client you would be OK. You need 1 copy to point Razor/UOS to when playing on the friend's server. You need another copy that your server points to for access to the MUL and UOP files. You need a 3rd copy to point Razor/UOS to when playing on your own server.
 

Ishya

Citizen
Yes I had two versions of Ultima installed on my computer! Classic client and mondains. once I uninstalled mondains I was good to go. you can still use it all you have to do is zip it before you uninstall and then you can unzip and point whatever you are using it for to where you put it. If thatmakes sence great if not PM me and I will try to explain it better! Sorry it took me so long to answer been away and unable to get to a computer.