Editing UOP Files with Newest Version of CentrED+

Archaaz

Squire
Greetings,

I noticed that the most recent version of CentrED+, 0.7.09, claims to support UOP file format including artLegacyMUL.uop. Has anyone had success in getting this to work?

Thanks in advance!
 

AsYlum

Citizen
The problem with centred+ is that it supports uop but in some version of uop they have made changes to map files and there is extra block of data that is problematic for centred+. Which version of the client are you using?
 

Archaaz

Squire
For my own shard I use an older client with mul files. I am just curious to see if I can get this working with a newer client. I am experimenting with an unpatched 7.0.78.4 client, but my attempts to get CentrED+ to work with the legacy UOP map have been unsuccessful.
Post automatically merged:

For my own shard I use an older client with mul files. I am just curious to see if I can get this working with a newer client, maybe as part of a future project. I am experimenting with an unpatched 7.0.78.4 client, but my attempts to get CentrED+ to work with the legacy UOP map have been unsuccessful.
 

golfin

Rookie
Use an older version of the UO. Roughly until version 7.0.60- After this it will no longer work for you. But I have a feeling that StaticZ wrote somewhere that even older versions. When he released the last center, UO was around 7.0.24.
 

Archaaz

Squire
So, it would just be better to edit with mul files and convert to UOP if I wanted to use a newer client?
 

golfin

Rookie
No, new versions have a different size. Old I think your latest client won't want to tolerate it. I recommend developing UO on older versions. Roughly until 7.0.59. Unless you're remaking multis. If you want to edit multis, then 7.0.36. New maps will not load you for example centred +, or radmapcopy, etc.
 

AsYlum

Citizen
I've had few minutes so I checked the ced+ issues and it seems to work just fine with recent client files. I'm using ced+ with version 0.7.9 that is latest from Файлы - CentrEd+ - Quintessence and my map0 setup in cedserver.xml looks like so:

XML:
  <Map>
    <Map>map0LegacyMUL.uop</Map>
    <StaIdx>staidx0.mul</StaIdx>
    <Statics>statics0.mul</Statics>
    <Width>896</Width>
    <Height>512</Height>
    <Prefix>0</Prefix>
    <Format>0x18</Format>
  </Map>

If you want to use other maps in uop then you just update map file name, width and height in blocks and prefix 1, 2, 3, 4, 5. Sizes and all is described here Start and server setup - CentrEd+ - Quintessence only thing that is weird are flags in wiki. The flags example table values seems off.
 

Archaaz

Squire
I've had few minutes so I checked the ced+ issues and it seems to work just fine with recent client files. I'm using ced+ with version 0.7.9 that is latest from Файлы - CentrEd+ - Quintessence and my map0 setup in cedserver.xml looks like so:

XML:
  <Map>
    <Map>map0LegacyMUL.uop</Map>
    <StaIdx>staidx0.mul</StaIdx>
    <Statics>statics0.mul</Statics>
    <Width>896</Width>
    <Height>512</Height>
    <Prefix>0</Prefix>
    <Format>0x18</Format>
  </Map>

If you want to use other maps in uop then you just update map file name, width and height in blocks and prefix 1, 2, 3, 4, 5. Sizes and all is described here Start and server setup - CentrEd+ - Quintessence only thing that is weird are flags in wiki. The flags example table values seems off.

Many thanks for taking the time to look into this!