External Connections (win 10)

Andrew Burston

Citizen
Feb 26, 2017
13
0
1
34
For sum reason even though on my router i have opened the ports with a static port and with the new fangled port forwarding no one can connect externally.... any one had this issue before??
 

Vorspire

Vita-Nex: Core
Admin
ServUO Developer
Jul 29, 2013
1,164
269
83
33
United Kingdom
core.vita-nex.com
Shard Name
Ultima Shards: Multiverse
Donate
Donate money to this user
Been a while 'Drew, hope you're keeping well.

Do the players trying to connect show any signs of a connection attempt in the shard console?

If not, then your shard is likely listening on the wrong IP.

For example, if your computer's internal IP is 192.168.0.5 and you forward to x.x.x.5 on port 2593, then your shard listener should be listening to x.x.x.5 too - double check to make sure.

You will also need to add an inbound exception for your shard (by exe or port) to your Windows Firewall.
 

Nadious

Squire
Aug 5, 2016
104
5
18
42
Canyouseeme.org is a good site to check if your port forwarding is working. Go there (on a computer in your LAN), punch the port number in and check it. If it can't see the service behind it, then something may be misconfigured. Make sure your shard is running when you check for the service too.
 

Andrew Burston

Citizen
Feb 26, 2017
13
0
1
34
Been a while 'Drew, hope you're keeping well.

Do the players trying to connect show any signs of a connection attempt in the shard console?

If not, then your shard is likely listening on the wrong IP.

For example, if your computer's internal IP is 192.168.0.5 and you forward to x.x.x.5 on port 2593, then your shard listener should be listening to x.x.x.5 too - double check to make sure.

You will also need to add an inbound exception for your shard (by exe or port) to your Windows Firewall.
Hi Lee,

Yeah its been a while dude. How's things. ive got a new facebook account have re-added you.

http://canyouseeme.org/ Resault
Success: I can see your service on xx.xx.xx.64 on port (2593)

servUO console shows this

21:41:10 Client: 52.202.215.126: Disconnected. [0 Online]
21:43:20 Client: 52.202.215.126: Disconnected. [0 Online]

If i try to log into the server with razor using my external I.P address i get nothing just cant connect at this time and no attempt in the console.

as you can see by the image, it shows the canyouseeme.org attempt but not the client login attempt

i can however login on the 127.0.0.1 address
 

Attachments

Last edited:

Vorspire

Vita-Nex: Core
Admin
ServUO Developer
Jul 29, 2013
1,164
269
83
33
United Kingdom
core.vita-nex.com
Shard Name
Ultima Shards: Multiverse
Donate
Donate money to this user
I don't really use Facebook these days, but I'll accept at some point, lol.

Did you add a windows firewall rule for your shard?