getting this error how to fix this

dude57

Citizen
----------------------------------------------------------------------------
ServUO - [http://www.servuo.com] Version 0.4, Build 4999.23561
Publish 51
Core: Optimizing for 2 64-bit processors
OpenUO Error: Client files not found.
Scripts: Compiling C# scripts...done (cached)
Scripts: Skipping VB.NET Scripts...done (use -vb to enable)
Scripts: Verifying...
Finished (5282 items, 1293 mobiles, 11 customs) (1.33 seconds)
ACC Registered: Server.ACC.PG.PGSystem
Regions: Loading...done
World: Loading...An error was encountered while loading a saved object
- Type: Server.Items.Board
- Serial: 0x40000077
Delete the object? (y/n)
After pressing return an exception will be thrown and the server will terminate.
nnnnkcdjidfifif\
Error:
System.FormatException: Index (zero based) must be greater than or equal to zero
and less than the size of the argument list.
at System.Text.StringBuilder.AppendFormat(IFormatProvider provider, String fo
rmat, Object[] args)
at System.String.Format(IFormatProvider provider, String format, Object[] arg
s)
at Server.World.Load() in c:\Users\Michael\Documents\GitHub\ForkUO-1\Server\W
orld.cs:line 656
at Server.Core.Main(String[] args) in c:\Users\Michael\Documents\GitHub\ForkU
O-1\Server\Main.cs:line 648
This exception is fatal, press return to exit[DOUBLEPOST=1378669469,1378668746][/DOUBLEPOST]nvm think i fixed it[DOUBLEPOST=1378669716][/DOUBLEPOST]fixed it now it was the boards and logs scripts didnt not have the daat 99 systems on the using.daat99;
 

sec_goat

Citizen
That fixed the issue then? I don't have that call in my log.cs on my shard and no problems so far.

I did merge the pulls and uploaded to my server. Now I just need to update the resource pack!
 
Last edited:

dude57

Citizen
ok with out using.daat99; the server will try to delete the logs and boards then crash[DOUBLEPOST=1378681737,1378681353][/DOUBLEPOST]all u have to do is just edit them to files i add the daat99 system to should not have any problems after that with any thing that saves and my server been up for a while like 3 or 4 hours now since i updated them files :)
 

sec_goat

Citizen
I had similar issues when I first deployed daats but I had been running a shard for a while and some stuff just had to be deleted. After the first time those errors did not come back.

but just to err on the side of caution I added the using directives and will update the download soon.