1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Granite Mining with OWLTR 3.01

Discussion in 'Script Support' started by Doc, Apr 19, 2013.

  1. Doc
    Offline

    Doc Member

    Joined:
    Mar 21, 2013
    Messages:
    42
    Likes Received:
    0
    I'm kinda stumped here. Everything works fine with Owltr/FS ATS except my players cannot mine Stone (Granite) after reading the book for it and setting the tool to mine it and ore. Custom ore and Gem mining is just fine.

    Any pointers?

    Thanks!
     

    Attached Files:

  2. Milva
    Offline

    Admin Moderator

    Joined:
    Mar 3, 2013
    Messages:
    3,545
    Likes Received:
    389
    Hopefully some one will help you with this, I have never worked (merged) OWLTR in the past. One thing after reading the stone book and setting the shovel or pick to both ore and stone. With [props on the player does it show stonemining true and toggleminingstone true also?
     

    Attached Files:

    • Like Like x 1
  3. Doc
    Offline

    Doc Member

    Joined:
    Mar 21, 2013
    Messages:
    42
    Likes Received:
    0
    Thanks for replying Milva. I had this problem once beofore. The only way I found after picking over everything to allow granite to be mined again was to revert back to the old version of Daat99.. kinda odd. I'm sure it is something simple I'm missing that has changed or I forgot a line.. but I've poured over the merges and don't really see anything out of place. Yeah it does show the props as stonemining and toggleminingstone set to true. Gem mining works perfectly. I'll probably download a clean pull from git and try the merge again. Seems like starting from scratch often helps me catch something.

    Thanks a bunch!
     

    Attached Files:

  4. Milva
    Offline

    Admin Moderator

    Joined:
    Mar 3, 2013
    Messages:
    3,545
    Likes Received:
    389
    Hope you can get it worked out, I went over the 3 files and it seemed as though granite was listed where it should be. But then I'm not sure what was merged, sorry I couldn't help out more :)
     
    • Like Like x 1
  5. Doc
    Offline

    Doc Member

    Joined:
    Mar 21, 2013
    Messages:
    42
    Likes Received:
    0
    Hey, I sure do appreciate the time. I'll figure it out here sooner or later ;)
     
  6. Hammerhand
    Offline

    Hammerhand Active Member

    Joined:
    Mar 26, 2013
    Messages:
    801
    Likes Received:
    77
    Seems to actually be something in 2.3 thats causing issues with OWLTR. Granite mining works fine in 2.3 w/o OWLTR, its just with. Daat99 is aware of it & will begin working on it shortly.
     
  7. Hammerhand
    Offline

    Hammerhand Active Member

    Joined:
    Mar 26, 2013
    Messages:
    801
    Likes Received:
    77
    Fixed by adding the following code to GetDaat99HarvestedType method in ResourceHelper (before the current return code): line 68
    Code (C#):
    1. if (originalType.IsSubclassOf(typeof(BaseGranite)) && info.ResourceTypes.Length > 2)
    2.     return info.ResourceTypes[2];
    3.  
     
    • Like Like x 1
  8. Doc
    Offline

    Doc Member

    Joined:
    Mar 21, 2013
    Messages:
    42
    Likes Received:
    0
    Thank you! Sorry for the late reply, but I've been in the hospital 9 days. Doing well now. Good news to come back to :D
     
  9. Doc
    Offline

    Doc Member

    Joined:
    Mar 21, 2013
    Messages:
    42
    Likes Received:
    0
    Worked like a charm, thanks again. :)
     
  10. byaccident
    Offline

    byaccident New Member

    Joined:
    Jul 22, 2013
    Messages:
    25
    Likes Received:
    1
    I was just wondering , how the heck do you start implenting the owltr system in servuo?
    if i open the files with winmerge but the wole files seem different , guest it won't just be a copy paste job either.
     
  11. Milva
    Offline

    Admin Moderator

    Joined:
    Mar 3, 2013
    Messages:
    3,545
    Likes Received:
    389
    If the package is in zip or rar forum, you will need to open this first
    You will need winmerge in order to compare and change runuo files and owltr files, it won't be easy. Not unless some one will share their completed files :)
     
  12. byaccident
    Offline

    byaccident New Member

    Joined:
    Jul 22, 2013
    Messages:
    25
    Likes Received:
    1
    I think we aren't talking about the same thing Milva.
    I know how to add them to runuo using winmerge and how to unrar / unzip files.

    It's just when I open a file from the owltr and one from servuo winmerge shows it as 2 totally different files.

    tnx for the help
     
  13. Milva
    Offline

    Admin Moderator

    Joined:
    Mar 3, 2013
    Messages:
    3,545
    Likes Received:
    389
    So they both don't look as a cs script? Guess I'm not quite sure what you mean then :/ sorry.
     
  14. manofwar
    Offline

    manofwar Member

    Joined:
    Mar 22, 2013
    Messages:
    34
    Likes Received:
    7
    Hello byaccident, I know what you are talking about with winmerge, I am gonna tell you my setting in winmerge maybe it will help you. You will still see alot of yellow but not whole different files.

    One thing that causes that is dotnet 4 things they introduced into servuo.

    Ok here we go, open winmerge then under edit then options, under options then compare then general. make white space = ignore all. then under that check ignore blank lines, ignore case, ignore carriage return differences and match similar lines. Hope that helps you out some, it sure helped my merges so every file wasn't all yellow.
     
    • Like Like x 1
  15. byaccident
    Offline

    byaccident New Member

    Joined:
    Jul 22, 2013
    Messages:
    25
    Likes Received:
    1
    manofwar that seems to do the trick 1000 times ty
     
Similar Threads: Granite Mining
Forum Title Date
Custom Releases Granite Furness Oct 14, 2016
ServUO Discussion Granite and Fish... Jul 19, 2016
Custom Releases Granite Colossus Feb 3, 2016
Script Support Mining attempts crashes server Monday at 7:17 PM
General Discussion Mining Aug 1, 2017
Archived Bug Reports Mining Internal Items Bug Jun 5, 2017
Script Support Mining Golem???????????????? May 12, 2017