House Customizing Weirdness...

Tukaram

Rookie
I was building a new house, and ran into an odd problem. In the customize screen the house looks fine, it 'commits' fine. But... the actual finished house has a lot of stray staircases in it. They block movement on that floor. I have no idea where they came from or how to get rid of them. When I go back into customize - they are not, so cannot be removed. I tried my Admin account and could not 'remove' or 'move' them. I have reset the server, to no avail.

Other than demolishing the house and starting over (I would rather not)... any ideas on what to do or how it happened?

1.JPG 2.JPG
 

Falkor

Squire
I fought this battle years ago when I moved a shard from 5.9x to 7.x clients due to the artwork expansions over the years. It hinged on the
Code:
            TileMatrixPatch.Enabled = false; // OSI Client Patch 6.0.0.0

            MultiComponentList.PostHSFormat = true; // OSI Client Patch 7.0.9.0
settings in MapDefinitions.cs after actually implementing such things in a RunUO RC 2.0 server core.

However, I think you're running the current server with no old baggage to retain so those are probably already correct. I notice you're using the enhanced client -- do you have the same artifacts if you make a house using the classic client?
 

Tukaram

Rookie
It is a brand new shard, I had not tried Classic. BRB

Well... that seemed to fix it. In the classic client, the stairs were visible in the customize screen, so I deleted them. Still not sure what happened, but glad it was an easy fix ha ha. I would never have thought to look at it in Classic.
 

Caska

Citizen
I'm not a coder by any means, but the enhanced client seems to have a lot of issues with house customization. The roof will drop anything higher than 5 levels down to the floor below, but in CC you can use all 6 with no problem. Even if you love the EC, I'd recommend doing any house customization in CC.