Feynman

Citizen
Looks nice :)

Did you patch it over an existing animation or is it a new slot?
What about other items you can equip? Can you target them?
 

gokku

Citizen
no they are literally new animations with new slots. i didn't change any old animation to replace new ones.

and... also i added new items to equip like that. actually idea is simple i made new arts to link them with original ones.
 
Last edited:

gokku

Citizen
yea sure i can explain everything one by one but without any solution to my problem which i asked.. actually everything is pointless because it looks like un-natural.

still ride animation is not targetable when i ride it but my body is targetable.
 

m309

Moderator
I know you said you didn't think it was a tiledata issue. What is the weight of your mount item set at in Tiledata?
 

PyrO

Moderator
I am just thinking, could it be one of the client confs? The mobtypes.conf lists for example the tiger, tiger etheral and the unicorn?
 

gokku

Citizen
aa yeah that conf files.. they were really mess for me at the beginning of the process.. because some slots inside of anim/2/3/4/5 are for mounts some of are not..

anyway i was checking something and realized this problem what i mentioned its happening just for player chars. i made some scripts for npcs which they are riding these new mounts and target mechanic just working perfectly for them..

i believe just in a few days i'm gonna figure it out that problem what is the main reason. after that we can talk about how can we increase efficiency of the datas.
[doublepost=1483392805][/doublepost]almost forgot i realized the client can capable of mix some interesting tile infos with animations or etc.. for example we can do illuminated or foliaged animations with new integers.like..

shining mounts like lantern or something without coding.. just modifying the data

afjkaew.png..
 
I'm trying to take existing animations and edit their specific action animations, for example swap out "Pillage" animation with "Attack1", etc.

Should I use Michelangelo or Mulpatcher or UOFiddler to do this..? Or maybe something else?

Thanks in advance for the help and guide from the OP!
 

golfin

Squire
If you want to change part of the frames in the animation, you can use mulpatcher and also UO Fiddler. Michelangelo, I'm not sure he can disassemble an animation file.
 
@golfin Thank you for the reply. I would prefer to use UO Fiddler as I am most familiar with that, but I can't figure out how to change strictly just the frames like changing out "Pillage" frames for the "Attack1" frames as the example on a zombie mob.

In UO Fiddler's "Animation Edit" window I've tried to "import" and "export" individual frames - the problem is it imports the entire .vd animation file for that mob, even when selecting an individual frame like "walk" or "attack1" etc.

Is there another way that I am missing by chance?
 

golfin

Squire
I don't know. I don't use UO Fiddler for animations. Mulpatcher can export animation as images. And then you can freely edit them image by image. But it's very laborious. There are a lot of those pictures.
 

Fred1990

Citizen
Guys im using the UOFiddler , i want to change the anim 0x17 (23) the wolf when i change it appears always the wolf... not the custom mobs, same to the all on the anim.mul, with anim2 3 4 ecc no problems.

How can i resolve?
 

golfin

Squire
And how did you solve it, please. I couldn't understand the problem you had. Under normal circumstances, what he wrote should not happen. What was your problem and how did you solve it. Thank you.
 
Hi All

It has been quite time this topic released but I have a question. I was be able to manage to add new npcs. but I have to use existing npc Anim ID other wise anim does not show up.

In bodycon.def it says I should add new animal anims between 200-399 buy it doesnt work properly.

Bodycon.def says.

# 0 - 199 = MOnsters
# 200 - 399 = Animals
# 400 + = HUmans/Elves and Equipment

On bodycondf I used code like below. ,

221 -1 -1 221 -1 #LBR Polar // Anims coming fom anim4.mul 221 slot

New animation shows up like this.
1590502751571.png

If I use on bodycondf. like this below.

350 -1 -1 221 - 1#LBR Polar

animation doenst show up.


1590502896949.png

I just want to know why this is happened?

Note: Yes I did change the npc chardef in script when I change the Bodycon.def. Also closed and rerun the sphere for reload bodycon.def again.
Also checked, Is there any other anims on slot 350. FYI there is non.

Thank you for your support
Post automatically merged:

Hi All

It has been quite time this topic released but I have a question. I was be able to manage to add new npcs. but I have to use existing npc Anim ID other wise anim does not show up.

In bodycon.def it says I should add new animal anims between 200-399 buy it doesnt work properly.

Bodycon.def says.

# 0 - 199 = MOnsters
# 200 - 399 = Animals
# 400 + = HUmans/Elves and Equipment

On bodycondf I used code like below. ,

221 -1 -1 221 -1 #LBR Polar // Anims coming fom anim4.mul 221 slot

New animation shows up like this.
1590502751571.png

If I use on bodycondf. like this below.

350 -1 -1 221 - 1#LBR Polar

animation doenst show up.


1590502896949.png

I just want to know why this is happened?

Note: Yes I did change the npc chardef in script when I change the Bodycon.def. Also closed and rerun the sphere for reload bodycon.def again.
Also checked, Is there any other anims on slot 350. FYI there is non.

Thank you for your support
SOLVED!
 
Last edited:

TheArt

Rookie
Hi All

It has been quite time this topic released but I have a question. I was be able to manage to add new npcs. but I have to use existing npc Anim ID other wise anim does not show up.

In bodycon.def it says I should add new animal anims between 200-399 buy it doesnt work properly.

Bodycon.def says.

# 0 - 199 = MOnsters
# 200 - 399 = Animals
# 400 + = HUmans/Elves and Equipment

On bodycondf I used code like below. ,

221 -1 -1 221 -1 #LBR Polar // Anims coming fom anim4.mul 221 slot

New animation shows up like this.
View attachment 15741

If I use on bodycondf. like this below.

350 -1 -1 221 - 1#LBR Polar

animation doenst show up.


View attachment 15742

I just want to know why this is happened?

Note: Yes I did change the npc chardef in script when I change the Bodycon.def. Also closed and rerun the sphere for reload bodycon.def again.
Also checked, Is there any other anims on slot 350. FYI there is non.

Thank you for your support
Post automatically merged:


SOLVED!
How did you solve it? I need to be able to do this too so I can add custom critters. Please and thank you.
 
Hey, you need to check mobtypes.txt and define ANim ID as you wish to use, Like Animal Monster or wereable etc. If your Anim Id doesn't exist on mobtypes animation won't show up.
 

TheArt

Rookie
Hey, you need to check mobtypes.txt and define ANim ID as you wish to use, Like Animal Monster or wereable etc. If your Anim Id doesn't exist on mobtypes animation won't show up.
aaah, for some reason it doesn't work for mine but I found out why. Thank you for the response!