How to add custom animations to UO

  • If you would like to submit a tutorial please visit the main tutorial page here.
    You can not submit them from this forum.

TheArt

Rookie
Oct 21, 2018
97
57
18
Shard Name
Planes of Etria
Can you explain why :D Is it same problem or another one?
I had to replace animations with other animations. The client I am using doesn't support custom animations unless they are replace animations.
 

Erdinç Kudu

Citizen
Mar 25, 2018
7
0
1
29
Hi All,

I added new animation. But having trouble when I try to mount it :)

Added NPC anim to Anim5.MUL in 211 slot, here is UOfiddler picture.

1591801442273.png


Added anim number to Bodyconv.def

#animals
350 -1 -1 -1 211 #Griffin

Added scp to summon NPC, at this point everything is ok. :)

1591801619668.png


Now try to add anim in tiledata for mount it. Found empty slot and write animation number of Griffin

1591801783134.png

Like so, change mount scp. call 0x3FE8 while mounting NPC,

getting this error message,

ERROR:(i_memories.scp,634)Setting unknown base ID=03fe8 for base type i_mt_griffin_brown
Mounting someting else,

1591802099677.png


Try with another npc.

1591802176884.png

Result is same, Character mounting someting else.

1591802212043.png

Can someone help me about it?

Note: I'm using 7x Client , other muls coming from Uo.com classic client files.

It may happen client read anim UOP but I couldnt figure out how to open and read animation.UOPs
 

Erdinç Kudu

Citizen
Mar 25, 2018
7
0
1
29
Problem is solved,

I think I'am using broken tiledata slot thats why when I try to mount npc its not appear on client, find another empty slot and move animation slot from 350 to 1600. Its work just fine