Logout Delay not working

Operating System
Windows
ServUO Version
57-Beta
I've went into my region.xml and changed all regions to hold a logout delay, but still isn't working
 

Attachments

  • Regions.xml
    126.5 KB · Views: 1
Is there something i need to change elsewhere? i have <logoutDelay active="true" /> set on all towns and its still an instant delay?
Post automatically merged:

Is there something i need to change elsewhere? i have <logoutDelay active="true" /> set on all towns and its still an instant delay?
FIXED
 
Last edited:

Vorspire

Vita-Nex: Core
Administrator
ServUO Developer
What was the issue?
Was it that the delay doesn't apply to staff and that's how it was being tested?

Sometimes these things aren't too obvious.
If it wasn't that, it'd be great if you share the fix for others with the same issue.
 
Is there something i need to change elsewhere? i have <logoutDelay active="true" /> set on all towns and its still an instant delay?
FIXED
What was the issue?
Was it that the delay doesn't apply to staff and that's how it was being tested?

Sometimes these things aren't too obvious.
If it wasn't that, it'd be great if you share the fix for others with the same issue.
I was in Test Center mode for beta so i went into PlayerMobile.cs and change line 6177
Code:
        public override TimeSpan GetLogoutDelay()
        {
            if (Young || BedrollLogout || BlanketOfDarknessLogout || TestCenter.Enabled)
            {
                return TimeSpan.Zero;
            }

            return base.GetLogoutDelay();
        }
to this
Code:
        public override TimeSpan GetLogoutDelay()
        {
            if (Young || BedrollLogout || BlanketOfDarknessLogout)
            {
                return TimeSpan.Zero;
            }

            return base.GetLogoutDelay();
        }