1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Looking For some help porting OWLTR 3.01 to ServUO

Discussion in 'Script Support' started by sec_goat, Sep 4, 2013.

  1. sec_goat
    Offline

    sec_goat Member

    Joined:
    Aug 26, 2013
    Messages:
    110
    Likes Received:
    14
    Hello All!

    I am attempting to merge the New OWLTR 3.01 into the ServUO core. It appears that I am having trouble and I have an inkling that it has to do with some of the SA Features, particularly gem mining.

    So it appears that while mining using OWLTR the server will crash, but I think Only when Gem Mining is enabled. I tried but did not have the gem mining enabled and it did not crash.

    Code (C#):
    1. Exception:
    2. System.NullReferenceException: Object reference not set to an instance of an object.
    3.    at daat99.ResourceHelper.GetDaat99HarvestedType(Type originalType, Boolean prospected, Double skill) in c:\ServUO\ServUO\Scripts\Custom Systems\OWLTR 3.01.00\New\Resource Helper.cs:line 70
    4.    at Server.Engines.Harvest.HarvestSystem.FinishHarvesting(Mobile from, Item tool, HarvestDefinition def, Object toHarvest, Object locked) in c:\ServUO\ServUO\Scripts\Services\Harvest\Core\HarvestSystem.cs:line 161
    5.    at Server.Engines.Harvest.HarvestSoundTimer.OnTick() in c:\ServUO\ServUO\Scripts\Services\Harvest\Core\HarvestSoundTimer.cs:line 31
    6.    at Server.Timer.Slice() in c:\ServUO\ServUO\Server\Timer.cs:line 425
    7.    at Server.Core.Main(String[] args) in c:\ServUO\ServUO\Server\Main.cs:line 675
    I have asked the lovely creators over at RunUo as well, but I figure the problem is more with the SA mods we have here, so I am hoping some one can help me get past this so we can add this as a release for ServUO as well.

    thanks!
     

    Attached Files:

  2. sec_goat
    Offline

    sec_goat Member

    Joined:
    Aug 26, 2013
    Messages:
    110
    Likes Received:
    14
    In the past when trying to merge custom resources into SA cores I ran into issues where SA was trying to return the resource type of gem or Resource[2] when it was not defined, I think this is the same kind of issue, I just cannot track down the proper place to modify the code.

    here is a thread where I had some help with a similar issues:
    http://www.runuo.com/community/thre...als-powders-mining-error.462745/#post-3633033

    not sure if the two are related but it sure seems like it.

    I continue to research and ask around for a solution.

    thanks!

    EDIT: even if some one can just hold my hand through how the small gem mining works now, I really feel this is the problem.
     
    #2 sec_goat, Sep 5, 2013
    Last edited: Sep 5, 2013
  3. sec_goat
    Offline

    sec_goat Member

    Joined:
    Aug 26, 2013
    Messages:
    110
    Likes Received:
    14
    Never mind all I have found my issue and I believe I have resolved it!
    I will work on packing up all the merged files and releasing it in the release section so that you can have Daat99's OWLTR on SERVUO as well.

    I am sure there will need to be some merge issue or other bugs that I have inadvertently introduced, but it is looking good so far!
     
  4. pall
    Offline

    pall Member

    Joined:
    Aug 20, 2014
    Messages:
    166
    Likes Received:
    6
    hey, i have the same problem. when player mining say me this:

    Code (C#):
    1. 10:46:01 Error:
    2. 10:46:01 System.NullReferenceException: Object reference not set to an instance of an object
    3.   at daat99.ResourceHelper.GetDaat99HarvestedType (System.Type originalType, Boolean prospected, Double skill) [0x00000] in <filename unknown>:0
    4.   at Server.Engines.Harvest.HarvestSystem.FinishHarvesting (Server.Mobile from, Server.Item tool, Server.Engines.Harvest.HarvestDefinition def, System.Object toHarvest, System.Object locked) [0x00000] in <filename unknown>:0
    5.   at Server.Engines.Harvest.HarvestSoundTimer.OnTick () [0x00000] in <filename unknown>:0
    6.   at Server.Timer.Slice () [0x00000] in <filename unknown>:0
    7.   at Server.Core.Main (System.String[] args) [0x00000] in <filename unknown>:0 Crash: Generating report...done
    8. 10:46:01 Crash: Backing up...done
    9. 10:46:01 This exception is fatal, press return to exit
    how you solve this problem?
     
Similar Threads: Looking help
Forum Title Date
Looking For Help Looking for help (bridge servuo<->xenforo) Jul 22, 2017
Looking For Help Looking For Help Jun 26, 2017
Script Support OWLTR 4.0 BasedRange.cs Problem, looking for help Apr 15, 2017
General Discussion Looking for C# Programmer to help develop Server Mar 13, 2017
Looking For Help This Forum is for Servers looking for help Mar 4, 2017
Looking For Help Attempting to create a new UO experience, looking for help! Feb 7, 2017
Shards Looking For Players Blood drained looking for some players to help out! Nov 26, 2016