Amalek

Citizen
hello everyone, I'm new to this forum . I need advice and help , in my old RunUO had a system of evolution animals and monsters and I would get on ServUo , the only problem that I had helped my anico to make the system since I am one scripter low level , I potte help find a similar system or advise how to start building this system ?? I'd be very grateful , sorry for my bad English but use google translator ...
 

Amalek

Citizen
Thanks to the timely Much to the timely response ... I will try to install it and see if I'll be able to release an updated copy ... thanks again and sorry for the trouble
 

Milva

Moderator
I have this xantos package, if you don't mind not having the mercenary
You could test this package out also- has quite a few evo's which I had added
Need this Utilities package also (Evo Package and this all go into the Custom Folder
 

Attachments

  • EVO System.rar
    75 KB · Views: 397
  • Utilities.rar
    12 KB · Views: 308
Last edited:

Amalek

Citizen
thanks .. dumping or try to install so then tell you if it works ... thanks again I will know soon ...
 

ExX

Citizen
Hey Milva. Just curious did you make any tweaks to the system? I remember the dragon being insanely powerful. lol
 

Milva

Moderator
I didn't tweak the evo's-from what I can remember-the dragon as you stated would be the most highly uber :) but then I think most all evo's are. You could maybe do some adjustments to stats on it. I can check this system out again tomorrow to refresh all which I had with it.
 

ExX

Citizen
Yea it's one of those things on my long to-do list cause they are pretty uber. (I feel old saying uber lol) Thanks for sharing though, nice to have some additonal ones already made.
 

Milva

Moderator
For the dragon you could go into the DragonEvoSpec.cs script and play around adjusting this area
Remove a skill or adjust the stats
m_Skills = new SkillName[7] { SkillName.Magery, SkillName.EvalInt, SkillName.Meditation, SkillName.MagicResist,
SkillName.Tactics, SkillName.Wrestling, SkillName.Anatomy };
m_MinSkillValues = new int[7] { 50, 50, 50, 15, 19, 19, 19 };
m_MaxSkillValues = new int[7] { 120, 120, 110, 110, 100, 100, 100 };
 

Amalek

Citizen
thanks again for having responded to me ... I 'll explain that happens to me and by the time I use a RunUO 2.0 final repack ... but since that my pg are getting bored of the classic RunUO wanted to update it a bit ... in my RunUO 2.0 I already have all these things , evopet , evoweapon , this custom etc .. and I wanted to implement ter mur higs and sea ... but the RunUO 2.0 does not let you do this .... you advice about how to solve this problem ?? thanks again the attention
 

Milva

Moderator
This would take so much in changes to accomplish-not only for the map but also with gargoyle and such. If your server is not live yet you might want to consider switching to ServUO, now please remember this is only a suggestion :) What patch number for the server game client be at?
 

ExX

Citizen
I agree with Milva. I was in the same position you were in a little over a month ago and decided it was way to much of a headache to try and update RunUO. I ended up switching to JustUO just because it has more of a recent update, BUT JustUO and ServUO are both great updated distros. Both are very similiar and SevUO has a more active community. As Milva said these are just my opinions but I do suggest just grabbing one if possible. They either come with the system you are asking about or have posted versions available for most of them.
 

Amalek

Citizen
and my intention to go to servUO , but I'm so sorry to lose all my custom script .... and for what I 'm wiggling for upgrades ... although the road easier and to change server . .. indeed a RunUO 2.0 client 6.10.0 , a servUO with clkient 7.0.41 ... only I repeat that I have so many scripts in the custom ....... are very undecided about what to do:confused::confused::confused::confused:
 

ExX

Citizen
There is some good news. ServUO is not a completely different emulator. It is simply a more up to date fork of RunUO so most of if not all of your custom scripts will still work perfectly fine. When I upgraded to JustUO I had a large folder of custom scripts too and nearly all of them compiled and worked fine. There was only a couple I had to make minor changes to. That's just my experience though, Maybe I was super lucky. lol
 

Amalek

Citizen
I am now changing the script to keep my custom . but I 've got a big problem with FS animal taming system on January 2 ... I mean the other uses a system Xanthos , and in this I just can not get it started .. I 'm wiggling so much to make it work but I can not ... and eliminating this system would seize me a heart attack ...
:mad::mad::mad::):):)
 

Amalek

Citizen
the only problem now addressed , but I can not fix it :
mercenary.cs: CS0029: Line 447: cannot implicity convert type 'System.DateTime' to 'long'
I can not understand that I do ... I can help out ?
 

Milva

Moderator
I had the mercenary disabled :) but try this for your error
Change:
NextActionTime = DateTime.Now;
To:
NextActionTime = Core.TickCount;

Also if you have FSTaming and the Evo's- you will need to go into the FSTaming Settings I believe and add all evos there for not to breed- because the FSTaming returns a pet from the animal trainer- but the evo returns an egg from the pet which was breed
Other wise you will experience a crash when a ticket is turned in for an evo
 

Amalek

Citizen
thank you so much ... now it works .... you are really grateful as I said ... I 'm a scripter low level .. so I would not have found alone ... thank you so much more , I hope to be able to use this server for my players ... thanks again so much ...
 

Amalek

Citizen
sorry I have one last problem ... I inserted the system Daat99 ... before I make a copy of my original script ... I enter ila folder , delete the file that tells me that the core are double ... get to the end , now gives me a problem Championstype ... I find most of the bosses champ .. I change championSpawntype.cs , add the champ craft .. and I do not find the boss of any champ ... why ?? Now I do not know how to put this image of what I said the core ... but if you have already had this problem I would be very, very much appreciate it if you give me a hand with this last problem ... so I moved all my files to the new server
 

Milva

Moderator
Could you please post this in script support-as you will get more help if posted there
Also explain exactly what you merged with this system :)
 

Xanthor

Citizen
By any chance, was this ever completed and under a different name? Im getting the same exact errors and before wasting anyones time and do double work on a old great script, I see this is from 7 months ago, wondering if this is under another name.
 

Milva

Moderator
Which Xanto's did you download, the one from runuo or the one which I posted on the first page?
 

Xanthor

Citizen
Which Xanto's did you download, the one from runuo or the one which I posted on the first page?
I downloaded from first page the two files which after running gave me an error was missing shrink system so.did a search which was offsite for entire package so just unzipped the shrink script into the Xanthos folder and got all the errors above.
 

Milva

Moderator
Question do you have the Shrink Conf xml file in your Data Folder? With out downloading the package again to see if I had this in the Xantos package?
 

Milva

Moderator
Just tested this with Servuo build 5739.14180 ( I still have mercenary disabled) I'm not geting errors so not sure whats up :)
Xantos1.JPG Image2.jpg
 

Xanthor

Citizen
Just tested this with Servuo build 5739.14180 ( I still have mercenary disabled) I'm not geting errors so not sure whats up :)
View attachment 4603 View attachment 4604
Glad you mentioned about the shrink cfg file, because I see one not from what I added so going to redownload and try again. For some reason, the shrink options dont show up but if I get the system running, Ill post everything here so others can do the same.

I'm edditing this so I don't spam. I made some changes, which stopped the errors. I haven't ran a UO server in I can now say 10 years, which is when I shut down my server I thought for good when my daughter was born. It was both my kids interest in UO that got me to start it up again. They got tired of minecraft and were showing me old videos which shocked me, they were the old flash films by Ed Mcmanus and my kids saw the dragons and other monsters and thought they were just animations until I got the new servuo running. Took a day for them to start exploring, they were too busy trying to /kill the other first. Reminds self to think twice on giving gm access to ones own kids. Anyway, I put the files, even the one missing from the Xanthos folder in and servers running fine, no errors. I put them here: H:\ServUO-master\Saves\Customs\Xanthos. I read the readme files, and I used your two plus the shrink one, and now here is my only problem. I remember this program from 15 years ago, and can't for the life of me get any of the features to show up, not even the pet leash. Not even the [Shrink command works. There something else I need to do?
 
Last edited:

Xanthor

Citizen
If you need the shrink I can post this

Turned out I was using the wrong folder. This is what I did to correct the issue:

Inside the scripts folder I made a folder called customs, then I made a folder inside customs called Xanthos. Inside the Xanthos folder I copied the 3 folders EVO System, Shrink System, and Utilities.

far as it goes, everything loaded though there was one error that didn't affect the server::

Xanthos.Utilities.ConfigParser attempting to load Data/ShrinkConfig.xml...
Xanthos.Utilities.ConfigParser failed.

Funny, the search engine showed nothing, yet google shot me back to here with a post that had the file that fixed the error. All is running fine now. Here is the link for the file for anyone else having same issue. Just copy this ShrinkConfig.xml into the data folder.

https://www.servuo.com/attachments/shrinkconfig-rar.869/
 
Last edited:

Xanthor

Citizen
Actually have a new issue with the pet evo system. No errors, this is a bug and not sure where to look so I can try fixing it. The object of the system is once you hatch the egg, you set the pet onto whatever it can hunt without getting it killed. It accumulates exp and grows. Thats what is supposed to happen, but after trying both dragon and frenzied ostard, neither are gaining exp for their kills, they are stuck at 0. Tried this on normal account in case it was an issue with an admin account, and still nothing.
EDIT:
Discovered that the only way to evolve the pets is with training elemental. Going to attempt incorporating the system into the regular game. Pointless and not much fun if your stuck using one training ele to evolve when you have a whole world of spawns that you can train on instead. Besides, Im a bit miffed at some of the code. One of the eles was tagging along, so I attacked it in mortal mode to get rid of it because my pet I was testing, was at its limit and wouldn't attack it anymore. My suprise when it instant killed me. Spent a good hour reorganizing all the garbage I had on me lol.
 
Last edited:

Jarick

Citizen
I have this xantos package, if you don't mind not having the mercenary
You could test this package out also- has quite a few evo's which I had added
Need this Utilities package also (Evo Package and this all go into the Custom Folder


I load in up gives me all sorts of errors
 

Jarick

Citizen
Many used this system (I'm sure it will need updating) have not seen a release of updated quite yet
http://www.runuo.com/community/threads/runuo-2-0-rc1-xanthos-evo-system.73488/


Errors:
+ scripts 1 of 2/Customs/Jarick Custom Scripts/Evo System 2.1/Xanthos/EVO Syste
m/Mercenary/Mercenary.cs:
CS0246: Line 309: The type or namespace name 'AnkhEast' could not be found (
are you missing a using directive or an assembly reference?)
CS0029: Line 447: Cannot implicitly convert type 'System.DateTime' to 'long'

Scripts: One or more scripts failed to compile or no script files were found.
- Press return to exit, or R to try again.

The error i am getting
[doublepost=1465582738][/doublepost]This is the file it says is off
 

Attachments

  • Mercenary.7z
    4.9 KB · Views: 21

Milva

Moderator
You now have 3 different posts for Evo's - the package which I posted had the mercenary disabled :/ Try removing that line
 

uohazzard

Citizen
Is there anyways to manually evolve the pet?
[doublepost=1481832985][/doublepost]Is this working for everyone? I got some error about shrinkfile system
 

Tim

Citizen
make sure that you have the shrinkconfig.xml in your data folder . Should help but need to post error I might be able to help. I have had some experience with system.
 

uohazzard

Citizen
ok I got this to work on runuo.. but now that I am trying to get ths to run on the latest version of servuo i get the following errors, please help

--------------------------------------------------------------------------------
ServUO - [http://www.servuo.com] Version 0.5, Build 6193.26843
Publish 54
Core: Optimizing for 8 64-bit processors
RandomImpl: CSPRandom (Software)
Core: Loading config...
Scripts: Compiling C# scripts...Failed with: 4 errors, 0 warnings
Errors:
+ Custom/Xanthos/[ServUO.com]-EVO System/EVO System/AI/EvoArcherAI.cs:
CS0115: Line 24: 'Xanthos.Evo.EvoArcherAI.EndPickTarget(Server.Mobile, Server.Mobile, Server.Mobiles.OrderType)': no suitable method found to override
+ Custom/Xanthos/[ServUO.com]-EVO System/EVO System/AI/EvoBerserkAI.cs:
CS0115: Line 24: 'Xanthos.Evo.EvoBerserkAI.EndPickTarget(Server.Mobile, Server.Mobile, Server.Mobiles.OrderType)': no suitable method found to override
+ Custom/Xanthos/[ServUO.com]-EVO System/EVO System/AI/EvoMageAI.cs:
CS0115: Line 24: 'Xanthos.Evo.EvoMageAI.EndPickTarget(Server.Mobile, Server.Mobile, Server.Mobiles.OrderType)': no suitable method found to override
+ Custom/Xanthos/[ServUO.com]-EVO System/EVO System/AI/EvoMeleeAI.cs:
CS0115: Line 24: 'Xanthos.Evo.EvoMeleeAI.EndPickTarget(Server.Mobile, Server.Mobile, Server.Mobiles.OrderType)': no suitable method found to override
Scripts: One or more scripts failed to compile or no script files were found.
- Press return to exit, or R to try again.
[doublepost=1481856852][/doublepost]This has a fix here for anyone else needing it.

https://www.servuo.com/threads/help-with-xanthos-evo-system.5906/#post-38838