Port forwarding.. help?!

I apologize in advance if this is in the wrong forum.

ANY help would be appreciated! ive been at this allll day :(

. I have been trying to make my shard public literally all day. and now I am finally where I need to be ...I think. I am on my router website trying to open my port for UO. I was just wondering if you happen to know what I need to put in there? I checked the box labeled "enable" for "description" I put "UO" and then there's a box for "inbound port" (I'm not sure what to put there.. is that the port for 2593?) then there is "Type" and the options are TCP, UDP, or both TCP and UDP. I put both, because I wasn't sure. Then there is a box labeled "private IP address" that would be my local ip or the static IP I created, correct? and then last but not least there is a box labeled "Private Port" .. not too sure what to put there. Any help id appreciate! I have been at this all day, thank you :)
 
So, ALL day today.. I have been trying to figure out how to make my shard public. I've tried all different ways. finally I thought I did it right. I went to my router web browser, and did the port forwarding so that the firewall wouldn't effect anything. And it's still not working, I don't know what to do. I don't know if i'm typing it in the ServUO file wrong.. or what to do.. but any help would be appreciated.. please :( I'm out of ideas.
 

arvoreen

Citizen
I apologize in advance if this is in the wrong forum.

ANY help would be appreciated! ive been at this allll day :(

. I have been trying to make my shard public literally all day. and now I am finally where I need to be ...I think. I am on my router website trying to open my port for UO. I was just wondering if you happen to know what I need to put in there? I checked the box labeled "enable" for "description" I put "UO" and then there's a box for "inbound port" (I'm not sure what to put there.. is that the port for 2593?) then there is "Type" and the options are TCP, UDP, or both TCP and UDP. I put both, because I wasn't sure. Then there is a box labeled "private IP address" that would be my local ip or the static IP I created, correct? and then last but not least there is a box labeled "Private Port" .. not too sure what to put there. Any help id appreciate! I have been at this all day, thank you :)

Your guesswork is pretty good, nice job! Although I'm fairly sure you only need TCP for UO, forwarding both TCP and UDP shouldn't hurt anything. The inbound port 2593 is correct if using default UO ports. Private IP is the IP of the computer running the server, usually starts with 192.168. Private port would be the port UO is listening on for the computer running the server, which the default would be 2593 as well. This IP address will only work on your local network, you need the router's WAN ("outside") IP address to give to your friends. As UOFanta is suggesting, a noip.com account is really nice so you can give people a hostname instead of an IP address. I have a free account myself, and aside from having to click a link every 30 days to refresh it, it's great!
 
Usually port forwarding the router / modem should do it.

Try something like http://canyouseeme.org/ with the servers port number once its running to just check outside (public users) can get to the server, you should see in the console window an IP number pop up when it pings the server.
 
So, on the router web browser to add a virtual server there is an inbound port and a private port.. should they both be 2593?
[doublepost=1489779746][/doublepost]in "private ip address"for the virtual server, do I put anything? its already 192.168.2.x (no last number)
 

arvoreen

Citizen
Yep, both 2593 if you're using everything default. The "private ip address" needs to be the IP of the computer running the server. Easiest way to get this is press windows key + R to get the Run box, type "cmd" in the box (no quotes), then at the command prompt that comes up, type "ipconfig" (again no quotes) and press enter. You're looking for the "IPv4 address" (that's what it is on my Windows 7 at least).
 
20170317_155048.jpg 20170317_155111.jpg 20170317_155252.jpg this is what everything looks like... (notice there's no "serverlist" popping up in ServUO) 20170317_154840.jpg
[doublepost=1489780701][/doublepost]I don't know if I'm typing it wrong into the files in ServUO or what..argh :(
[doublepost=1489780857][/doublepost]
This is a double post so I'm going to combine them


Sorry for the double post. I didn't even realize. ive been having so much trouble with this.. about to pull my hair out :( been trying to figure it out for a day and a half.
 

arvoreen

Citizen
That all looks correct. The weirdness that I'm seeing is that your router says your WAN IP is a 192.168.x.x address, which are reserved for internal networks, so this indicates that you have a router plugged into a router, and we need to configure the router at 192.168.1.1 to forward port 2593 as well. If that even works, I've never tried forwarding through multiple routers.
 
ohh yeah. I live in a duplex, my router is just plugged into the main router..
[doublepost=1489781036][/doublepost]so what info do I need to get from the main router?
[doublepost=1489781081][/doublepost]Go to the web browser for the main router and open up a port ?
 

Lokai

Moderator
Just to clarify. You have one Router providing 192.168.2.150 to your PC, then you have ANOTHER router, which uses 192.168.1.x, so that I think is why there is confusion.
 

arvoreen

Citizen
I guess you'd want the main router to forward port 2593 to 192.168.1.2 port 2593, which would theoretically forward it to 192.168.2.150 as you already set up. We hope. :)
 
Just to clarify. You have one Router providing 192.168.2.150 to your PC, then you have ANOTHER router, which uses 192.168.1.x, so that I think is why there is confusion.

I appreciate the help.. what info do I need to get from the main router? I live in a duplex and just have a router plugged into the main router so it reaches my side of the house..
 

arvoreen

Citizen
You would need to set up port forwarding on the main router same as you did on the one we're looking at, just using 192.168.1.2 as the private ip, 2593 for ports all around
 
I guess you'd want the main router to forward port 2593 to 192.168.1.2 port 2593, which would theoretically forward it to 192.168.2.150 as you already set up. We hope. :)

Okay, so go to the web browser for the main router. enable a port.. then "inbound port" 2593, desc. "Uo" , "Private IP" 192.168.1.2 , "Private port" 2593?
 
ahhh thank you all so much! I will try that in a minute, and let you know how it turns out. I really do appreciate you taking the time to answer my silly questions .. it really means a lot.
 

Lokai

Moderator
If that does not work, another option is to forget all of that business with your routers and install something like Hamachi.