Thagoras

Diamond Sponsor
ServUO Version
Publish Unknown
Ultima Expansion
Stygian Abyss
The Backstory:
I hate Windows 10....to the point that I'm going back to Windows 7 for the live server. Unfortunately, the system I use regularly is 10...it's also where I test my server before I make it live.
When I got the system, I don't recall having any trouble getting everything to work right...I don't know...maybe I just installed enough software that the interdependencies worked on their own. Anyway, after numerous issues the system developed from trying to update Ark...I came to the realization that I just needed to reinstall the cursed operating system (it's good to reinstall annually if the system gets a lot of use...just because Microsoft has always had issues with the registry getting super cluttered).

The issue:
Crash Log:
Server Crash Report
===================

RunUO Version 2.1, Build 8167.17157
Operating System: Microsoft Windows NT 6.2.9200.0
.NET Framework: 4.0.30319.42000
Time: 5/12/2022 10:51:49 AM
Mobiles: 10
Items: 153
Exception:
System.DllNotFoundException: Unable to load DLL 'zlib64': The specified module could not be found. (Exception from HRESULT: 0x8007007E)
   at Server.Network.Compressor64.compress2(Byte[] dest, Int32& destLength, Byte[] source, Int32 sourceLength, ZLibQuality quality)
   at Server.Network.DisplayGumpPacked.WritePacked(PacketWriter src) in d:\UltimaOnline\UOGondolin\RunUO-Gondolin\Server\Network\Packets.cs:line 2312
   at Server.Network.DisplayGumpPacked.Flush() in d:\UltimaOnline\UOGondolin\RunUO-Gondolin\Server\Network\Packets.cs:line 2279
   at Server.Gumps.Gump.Compile(NetState ns) in d:\UltimaOnline\UOGondolin\RunUO-Gondolin\Server\Gumps\Gump.cs:line 410
   at Server.ACC.CSS.Modules.ApplyIcons.EventSink_Login(LoginEventArgs args)
   at Server.LoginEventHandler.Invoke(LoginEventArgs e)
   at Server.EventSink.InvokeLogin(LoginEventArgs e) in d:\UltimaOnline\UOGondolin\RunUO-Gondolin\Server\EventSink.cs:line 1194
   at Server.Network.PacketHandlers.DoLogin(NetState state, Mobile m) in d:\UltimaOnline\UOGondolin\RunUO-Gondolin\Server\Network\PacketHandlers.cs:line 2067
   at Server.Network.PacketHandlers.LoginTimer.OnTick() in d:\UltimaOnline\UOGondolin\RunUO-Gondolin\Server\Network\PacketHandlers.cs:line 1935
   at Server.Timer.Slice() in d:\UltimaOnline\UOGondolin\RunUO-Gondolin\Server\Timer.cs:line 387
   at Server.Core.Main(String[] args) in d:\UltimaOnline\UOGondolin\RunUO-Gondolin\Server\Main.cs:line 511

The server loads just find....but it crashes immediately as my mobile is moved to world. It's not just this shard, I've tried others and they all do the same. It's not client specific either, as the other shards use different clients. The .dll's are in the server folders. I've tried copying them to the system32 folder (and other places Windows might look) but it doesn't help.

I know this is a Windows issue but I can't think of what I'm missing. Any help would be greatly appreciated!

As a side note, I can't get GogGalaxy to install because it says that I'm missing Service Pack 1. I was under the impression that 10 kept up to date. I bring that up because the two issues feel like they might be connected in some way.
 

PyrO

Moderator
 

Thagoras

Diamond Sponsor
Thanks, but that was one of the first things I tried....

Okay....something with the redistribution package that comes with Sins of a Solar Empire fixed it. :rolleyes:
 

PyrO

Moderator
Hmm odd that the linked one didnt work for you.

As it is the needed version.

But as long as it works for you now? Thats good :)