Something's wrong with [CreateWorld

Lucian

Citizen
I just Created world in my server with [CreateWorld command and checkbox every one .
But ServUO errors :
upload_2017-3-19_14-32-0.png

And When I reopen server It says this :
upload_2017-3-19_14-37-25.png
 

Hammerhand

Rookie
You now have a bad save. Delete it & replace it with one from the backup folder. And that wasn't exactly a ServUO error. Your server went into save mode while trying to run the CreateWorld. Which is what ultimately caused the corrupted save.
 

Talow

Citizen
I think that would be the best thing to do, besides, who wants to create world more than once? So it would I'd assume be used sparingly and would be the least disruptive, then you could simply end the Create world command with a save anyways since it created so much.
 

m309

Administrator
ServUO Developer
Lucian, in the meantime prior to this being repaired in the repo, you could probably just disable your server from saving automatically (or set the timespan to something that won't trigger like 1 day), fire it up, run create world, manually save, shutdown. Then reactivate the automatic save to your normal interval and fire it back up.
 

Milva

Paladin
Yes you can also change the save time in Config/Server.cfg----open this folder (Server) scroll down looks as though saves are set to 5 min. change to maybe 30 min, can always change this back :)
 

Ravenwolfe

Moderator
ServUO Developer
Just do [setsaves false
Then use [createworld
Then do [setsaves true

No need to recompile or shut the server down.
 

Lucian

Citizen
I disabled autosave but when I createworld again it failed again..
It says Ultima Art : Unable to read client files
again..
 

Lucian

Citizen
I edited DataPath.cfg like this :
Is that true ?
( Program Dosyaları (x86) means Program Files (x86) in Turkish )
upload_2017-3-22_17-22-3.png
 

Milva

Paladin
Not sure what you have before Custom Path but remove it -shouldn't be anything there :) if this doesn't work- Do you have a folder named just Program Files? If so try moving ServUO and the game client there .
 

Ravenwolfe

Moderator
ServUO Developer
Just set it like this..

# Uncomment this line and set it to the path of the client files to set a
# custom data path. Otherwise ServUO will look for the client in the default
# Windows installation directories. Note that this is *required* when running
# on non-Windows systems.
CustomPath=C:\Program Dosyaları (x86)\Electronic Arts\Ultima Online Classic

You need to have it use the exact path to the files, since yours is Turkish, you will need to use the same language for the path.
 

Lucian

Citizen
Ok I will try both .
Program Dosyaları and
Program Files because when I copy and paste from Folder bar it turns Program Files