1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Something's wrong with [CreateWorld

Discussion in 'Script Support' started by Lucian, Mar 19, 2017.

  1. Lucian
    Offline

    Lucian Member

    Joined:
    Jul 2, 2016
    Messages:
    47
    Likes Received:
    0
    I just Created world in my server with [CreateWorld command and checkbox every one .
    But ServUO errors :
    upload_2017-3-19_14-32-0.png

    And When I reopen server It says this :
    upload_2017-3-19_14-37-25.png
     
  2. Hammerhand
    Offline

    Hammerhand Active Member

    Joined:
    Mar 26, 2013
    Messages:
    765
    Likes Received:
    73
    You now have a bad save. Delete it & replace it with one from the backup folder. And that wasn't exactly a ServUO error. Your server went into save mode while trying to run the CreateWorld. Which is what ultimately caused the corrupted save.
     
  3. Ravenwolfe
    Offline

    Moderator ServUO Developer

    Joined:
    Sep 7, 2013
    Messages:
    1,102
    Likes Received:
    117
    @Dexter_Lexia - Have seen this happen a few times, should we have [createworld disable saves until completed?
     
  4. Talow
    Offline

    Talow Member

    Joined:
    Aug 30, 2014
    Messages:
    287
    Likes Received:
    24
    I think that would be the best thing to do, besides, who wants to create world more than once? So it would I'd assume be used sparingly and would be the least disruptive, then you could simply end the Create world command with a save anyways since it created so much.
     
  5. Lucian
    Offline

    Lucian Member

    Joined:
    Jul 2, 2016
    Messages:
    47
    Likes Received:
    0
    I just created one time , and in a fresh server too . But It still same..
     
  6. m309
    Offline

    Admin Moderator ServUO Developer

    Joined:
    Mar 3, 2013
    Messages:
    1,243
    Likes Received:
    130
    Lucian, in the meantime prior to this being repaired in the repo, you could probably just disable your server from saving automatically (or set the timespan to something that won't trigger like 1 day), fire it up, run create world, manually save, shutdown. Then reactivate the automatic save to your normal interval and fire it back up.
     
    • Agree Agree x 1
  7. Milva
    Offline

    Admin Moderator

    Joined:
    Mar 3, 2013
    Messages:
    3,429
    Likes Received:
    385
    Yes you can also change the save time in Config/Server.cfg----open this folder (Server) scroll down looks as though saves are set to 5 min. change to maybe 30 min, can always change this back :)
     
  8. Lucian
    Offline

    Lucian Member

    Joined:
    Jul 2, 2016
    Messages:
    47
    Likes Received:
    0
    Thanks to all for all helps.
     
  9. Ravenwolfe
    Offline

    Moderator ServUO Developer

    Joined:
    Sep 7, 2013
    Messages:
    1,102
    Likes Received:
    117
    Just do [setsaves false
    Then use [createworld
    Then do [setsaves true

    No need to recompile or shut the server down.
     
    • Informative Informative x 1
  10. Lucian
    Offline

    Lucian Member

    Joined:
    Jul 2, 2016
    Messages:
    47
    Likes Received:
    0
    I disabled autosave but when I createworld again it failed again..
    It says Ultima Art : Unable to read client files
    again..
     
  11. Ravenwolfe
    Offline

    Moderator ServUO Developer

    Joined:
    Sep 7, 2013
    Messages:
    1,102
    Likes Received:
    117
    Try running ServUO as an admin.
     
  12. Milva
    Offline

    Admin Moderator

    Joined:
    Mar 3, 2013
    Messages:
    3,429
    Likes Received:
    385
    Agree with Ravenwolfe- also you have set your DataPath.cfg correct?
     
  13. Lucian
    Offline

    Lucian Member

    Joined:
    Jul 2, 2016
    Messages:
    47
    Likes Received:
    0
    I edited DataPath.cfg like this :
    Is that true ?
    ( Program Dosyaları (x86) means Program Files (x86) in Turkish )
    upload_2017-3-22_17-22-3.png
     
  14. Milva
    Offline

    Admin Moderator

    Joined:
    Mar 3, 2013
    Messages:
    3,429
    Likes Received:
    385
    Not sure what you have before Custom Path but remove it -shouldn't be anything there :) if this doesn't work- Do you have a folder named just Program Files? If so try moving ServUO and the game client there .
     
  15. Ravenwolfe
    Offline

    Moderator ServUO Developer

    Joined:
    Sep 7, 2013
    Messages:
    1,102
    Likes Received:
    117
    Take off the @ sign.
     
  16. Lucian
    Offline

    Lucian Member

    Joined:
    Jul 2, 2016
    Messages:
    47
    Likes Received:
    0
  17. Ravenwolfe
    Offline

    Moderator ServUO Developer

    Joined:
    Sep 7, 2013
    Messages:
    1,102
    Likes Received:
    117
    Just set it like this..

    # Uncomment this line and set it to the path of the client files to set a
    # custom data path. Otherwise ServUO will look for the client in the default
    # Windows installation directories. Note that this is *required* when running
    # on non-Windows systems.
    CustomPath=C:\Program Dosyaları (x86)\Electronic Arts\Ultima Online Classic

    You need to have it use the exact path to the files, since yours is Turkish, you will need to use the same language for the path.
     
  18. Ravenwolfe
    Offline

    Moderator ServUO Developer

    Joined:
    Sep 7, 2013
    Messages:
    1,102
    Likes Received:
    117
    And again, be sure to run ServUO as admin.
     
  19. Lucian
    Offline

    Lucian Member

    Joined:
    Jul 2, 2016
    Messages:
    47
    Likes Received:
    0
    Ok I will try both .
    Program Dosyaları and
    Program Files because when I copy and paste from Folder bar it turns Program Files
     
Similar Threads: Something's wrong
Forum Title Date
Archived Bug Reports Dungeon Wrong - Possible bug Yesterday at 1:09 PM
Archived Bug Reports Niporaliem - wrong hit points Aug 6, 2017
Archived Bug Reports When wearing out tools crafted items placed wrong Aug 1, 2017
Archived Bug Reports Carpentry - wrong success chances Jul 3, 2017
Archived Bug Reports Kotl Teleporter Bug (wrong area) Jun 21, 2017
ServUO Discussion AnimalTaming and Peacemaking seems wrong. May 31, 2017
Archived Bug Reports Pack Horse - Pack Llama Wrong Taming Skill May 22, 2017