1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

VitaNexCore 5.1.0.0

Discussion in 'General Discussion' started by john burns, Jul 11, 2018.

  1. john burns
    Offline

    john burns Member

    Joined:
    Mar 12, 2014
    Messages:
    676
    Likes Received:
    17
    Great system, but getting these errors:

    + Services/VitaNexCore/Misc/SpawnZone.cs:
    CS0227: Line 343: Unsafe code requires the `unsafe' command line option to be specified
    + Services/VitaNexCore/Text/UOFont.cs:
    CS0227: Line 193: Unsafe code requires the `unsafe' command line option to be specified
    CS0227: Line 564: Unsafe code requires the `unsafe' command line option to be specified
     
  2. Tasanar
    Online

    Moderator

    Joined:
    Oct 16, 2014
    Messages:
    4,042
    Likes Received:
    89
    What emulator are you using?
     
  3. john burns
    Offline

    john burns Member

    Joined:
    Mar 12, 2014
    Messages:
    676
    Likes Received:
    17
    here is the complete error report, the version number is one I dont know, but I downloaded the server files within the past month....

    ServUO - [https://www.servuo.com] Version 0.5, Build 6738.27069 - Build on 6/13/2018 3:02:18 PM UTC - Release
    Core: Running with arguments: -noconsole
    Core: Optimizing for 2 64-bit processors
    Core: Unix environment detected
    Core: Compiled for MONO and running on 3.2.8 (Debian 3.2.8+dfsg-10)
    RandomImpl: SimpleRandom (Software)
    Core: Loading config...
    Scripts: Compiling C# scripts...Failed with: 2 errors, 1 warnings
    Warnings:
    + _Customs/Spell-Bar-v2/SpellBarScroll_XML.cs:
    CS0642: Line 88: Possible mistaken empty statement
    CS0642: Line 651: Possible mistaken empty statement
    Errors:
    + Services/VitaNexCore/Misc/SpawnZone.cs:
    CS0227: Line 343: Unsafe code requires the `unsafe' command line option to be specified
    + Services/VitaNexCore/Text/UOFont.cs:
    CS0227: Line 197: Unsafe code requires the `unsafe' command line option to be specified
    CS0227: Line 568: Unsafe code requires the `unsafe' command line option to be specified
    Scripts: One or more scripts failed to compile or no script files were found.
    - Press return to exit, or R to try again.
     
  4. CrafterEric
    Online

    CrafterEric Member

    Joined:
    Aug 29, 2017
    Messages:
    54
    Likes Received:
    4
    I'm getting the same unsafe code error message from mine. I'm running Windows though, not Debian, and I'm running the Land of Archon repack.
     
  5. Tasanar
    Online

    Moderator

    Joined:
    Oct 16, 2014
    Messages:
    4,042
    Likes Received:
    89
    Do you have any custom regions scripts?
     
  6. john burns
    Offline

    john burns Member

    Joined:
    Mar 12, 2014
    Messages:
    676
    Likes Received:
    17
    I dont think so.

    oh god, I couldn't tell u that.

    let me check.

    and if its not that, then what?

    * * * * E D I T * * * *
    the only region thing related is for battlechess. but I see no custom region thing anywhere.
     
    #6 john burns, Jul 11, 2018
    Last edited: Jul 11, 2018
  7. Vorspire
    Offline

    Vorspire Vita-Nex: Core
    Admin ServUO Developer

    Joined:
    Jul 29, 2013
    Messages:
    1,041
    Likes Received:
    183
    Please read the FAQ page on the 5.1.0.0 resource page, I have updated it to cover this issue.
     
Similar Threads: VitaNexCore 5100
Forum Title Date
Issues VitaNexCore "UnSafe Command" to be specified Jul 12, 2018
Support VitaNexCore - Walk(me)through Jun 12, 2018
Support VitaNexCore - Voting error (happened out of the blue) Jul 11, 2017