Higler

Citizen
I know this not a runuo forum but im hoping someone might still be able to help as it has both devs at a loss after numerous hours of trying to fix. We are using runuo v2.3 and we are T2A expansion server but we are implementing ( or attempting to ) the bod systems for inscribe (yes i know runuo bod system causes nightmares) (eventually carpentry and tinker as well). I don't have any errors in VS or console and if I force add a small bod it does create a bod deed, but the bod doesnt have an item or amount and the bod gump says there a mega clioc error for the small bod, the large bod gives a amount but no item and no clioc error. The inscribe bods are almost identical to to the tailor and smith bod files and the vendor does have the code to call for a bod and I did add the .cfg files in the data/bulk order/inscription folder both large and small .cfg files were added. Posting my bod files and data files if any other files are needed please let me know to help figure it out. I did also try to recompile the server thinking maybe the cache for the data folder needed refreshed ( no idea how to refresh it without recompiling ) but that didn't work either. We did run a check on calling the bod and it hit the oncreaterandom method but it is saying there is 0 entries from the .cfg file. Any ideas or fixes are greatly appreciated
 

Attachments

  • LargeInscriptionBOD.cs
    3.2 KB · Views: 1
  • Scribe.cs
    2.6 KB · Views: 1
  • LargeBOD.cs
    7.6 KB · Views: 1
  • SmallBOD.cs
    9.1 KB · Views: 1
  • SmallBulkEntry.cs
    2.8 KB · Views: 1
  • LargeBulkEntry.cs
    5.4 KB · Views: 1
  • BulkMaterialType.cs
    763 bytes · Views: 1
  • Inscription.rar
    2.7 KB · Views: 1
  • SmallInscriptionBOD.cs
    5.3 KB · Views: 1

Iomega0318

Vita-Nex Sponsor
I'm not 100% sure as I don't use RunUO but I know formatting matters and I've had to fix a few issues related to BODs in the past.. here are how my inscription cfgs look...
 

Attachments

  • Inscription.zip
    3.3 KB · Views: 1
OP

Higler

Citizen
I'm not 100% sure as I don't use RunUO but I know formatting matters and I've had to fix a few issues related to BODs in the past.. here are how my inscription cfgs look...
Thank you so much for the help those unfortunately did not fix my problem. I am posting screen grabs of the issue so maybe it will make more sense. Again thank you everyone for any and all attempts to help.
 

Attachments

  • smallscribe.PNG
    smallscribe.PNG
    355.5 KB · Views: 10
  • largescribe.PNG
    largescribe.PNG
    358.4 KB · Views: 10
Last edited: