World won't load error

Dezzie

Well-Known Member
Oct 26, 2013
119
12
57
Shard Name
Darkness Once Forsaken
Donate
Donate money to this user
I'm getting this error now when my server restarts. I am guessing something is out of certain set bounds, but I don't know how to find out what it is.

1577738325223.png
 

Falkor

Well-Known Member
Apr 11, 2018
216
75
wpshard.com
Shard Name
Whispering Pines
It's telling you the file Bounds.bin doesn't exist. See if fixing that issue resolves the rest.
 

Dezzie

Well-Known Member
Oct 26, 2013
119
12
57
Shard Name
Darkness Once Forsaken
Donate
Donate money to this user
It's telling you the file Bounds.bin doesn't exist. See if fixing that issue resolves the rest.
That's what I thought, so I unzipped a previous working copy of the server and bounds.bin doesn't exist in it either????
 

Falkor

Well-Known Member
Apr 11, 2018
216
75
wpshard.com
Shard Name
Whispering Pines
It's used for determining the size of everything in TileData and it's downloaded as part of the ServUO source.

I don't know if it's the cause of the errors since ItemBounds.cs doesn't stop the server if the file is missing but instead just mentions the error -- does your working server also throw that warning during startup?
 

Dezzie

Well-Known Member
Oct 26, 2013
119
12
57
Shard Name
Darkness Once Forsaken
Donate
Donate money to this user
It's used for determining the size of everything in TileData and it's downloaded as part of the ServUO source.

I don't know if it's the cause of the errors since ItemBounds.cs doesn't stop the server if the file is missing but instead just mentions the error -- does your working server also throw that warning during startup?
Yes, the working server also has that warning.
 

Dezzie

Well-Known Member
Oct 26, 2013
119
12
57
Shard Name
Darkness Once Forsaken
Donate
Donate money to this user
I've added a bounds.bin in the data/binary folder and I'm still getting the rest of the errors and the server won't start.

I can't read code but I thought it was something to do with xml spawners that is the reason it won't start. I'm trying to remember if I made any changes to the spawners and I don't think I did. It is so weird to me that a server can restart a million times with no issues then not. Thanks for all the help, any other suggestions?

Does anyone know what unexpected end of file while parsing name has occurred. Line 2107 position 6
 
Last edited:

Falkor

Well-Known Member
Apr 11, 2018
216
75
wpshard.com
Shard Name
Whispering Pines
It looks like the error happens when worldload is parsing the accounts.xml file.

The next thing I would try is loading your most recent backup files over the contents of the Saves folder (or just rename Saves first). You could try restoring just the accounts file but that could leave you with unowned items in the world if there are accounts not present in the backup version.