Crash ServUO - Debian

fdesu

Member
Feb 25, 2019
15
1
31
Hi there,
I don't know how, but after a few ServUO Updates & mono i can't play now.
I did a fresh install of Debian and ServUO and the problem persist.

Whatever i make ([admin, skills,etc), the server go down.

Thanks

Regards!

C#:
Server Crash Report
===================

ServUO Version 0.5, Build 7032.25904
Operating System: Unix 4.9.0.8
.NET Framework: 4.0.30319.42000
Time: 4/3/2019 5:28:43 PM
Mobiles: 109
Items: 1256
Exception:
System.DllNotFoundException: libz
  at (wrapper managed-to-native) Server.Network.CompressorUnix64+SafeNativeMethods.compress2(byte[],long&,byte[],long,Server.Network.ZLibQuality)
  at Server.Network.CompressorUnix64.Compress (System.Byte[] dest, System.Int32& destLength, System.Byte[] source, System.Int32 sourceLength, Server.Network.ZLibQuality quality) [0x00004] in <cf72bcf6350b47619a7991c8dba4f741>:0
  at Server.Network.Compression.Pack (System.Byte[] dest, System.Int32& destLength, System.Byte[] source, System.Int32 sourceLength, Server.Network.ZLibQuality quality) [0x00000] in <cf72bcf6350b47619a7991c8dba4f741>:0
  at Server.Network.DisplayGumpPacked.WritePacked (Server.Network.PacketWriter src) [0x0008d] in <cf72bcf6350b47619a7991c8dba4f741>:0
  at Server.Network.DisplayGumpPacked.Flush () [0x00086] in <cf72bcf6350b47619a7991c8dba4f741>:0
  at Server.Gumps.Gump.Compile (Server.Network.NetState ns) [0x000d0] in <cf72bcf6350b47619a7991c8dba4f741>:0
  at Server.Gumps.Gump.SendTo (Server.Network.NetState state) [0x00007] in <cf72bcf6350b47619a7991c8dba4f741>:0
  at Server.Mobile.SendGump (Server.Gumps.Gump g, System.Boolean throwOnOffline) [0x0000b] in <cf72bcf6350b47619a7991c8dba4f741>:0
  at Server.Mobile.SendGump (Server.Gumps.Gump g) [0x00000] in <cf72bcf6350b47619a7991c8dba4f741>:0
  at Server.Gumps.AdminGump.Admin_OnCommand (Server.Commands.CommandEventArgs e) [0x00017] in <22d2e0d95f1e4c55b28a796fb0c6ec93>:0
  at Server.Commands.CommandSystem.Handle (Server.Mobile from, System.String text, Server.Network.MessageType type) [0x000bd] in <cf72bcf6350b47619a7991c8dba4f741>:0
  at Server.Mobile.DoSpeech (System.String text, System.Int32[] keywords, Server.Network.MessageType type, System.Int32 hue) [0x0000b] in <cf72bcf6350b47619a7991c8dba4f741>:0
  at Server.Mobiles.PlayerMobile.DoSpeech (System.String text, System.Int32[] keywords, Server.Network.MessageType type, System.Int32 hue) [0x000d7] in <22d2e0d95f1e4c55b28a796fb0c6ec93>:0
  at Server.Network.PacketHandlers.UnicodeSpeech (Server.Network.NetState state, Server.Network.PacketReader pvSrc) [0x00161] in <cf72bcf6350b47619a7991c8dba4f741>:0
  at Server.Network.MessagePump.HandleReceive (Server.Network.NetState ns) [0x0022a] in <cf72bcf6350b47619a7991c8dba4f741>:0
  at Server.Network.MessagePump.Slice () [0x00057] in <cf72bcf6350b47619a7991c8dba4f741>:0
  at Server.Core.Main (System.String[] args) [0x006e6] in <cf72bcf6350b47619a7991c8dba4f741>:0
Post automatically merged:

Solution:

Code:
# apt install zlib1g-dev
Thanks for the help.
 
Last edited: