sec_goat submitted a new resource:

Daat99's OWLTR 3.01 For ServUO - Custom ore, wood, leather, tokens and recipes

This is a Merge Of Daat99's OWLTR 3.01.00 for ServUO.

This shouldbe ok to drag and drop. overwrite the core files with the files in the Modified folder and leave the rest in your Custom release folder.


I will attempt to help troubleshoot any bugs that come up.

Read more about this resource...
 

Attachments

  • [ServUO.com]-[ServUO.com]-OWLTR 3.01.00.zip
    440 KB · Views: 202
Last edited by a moderator:
----------------------------------------------------------------------------
ServUO - [http://www.servuo.com] Version 0.4, Build 4999.17257
Publish 51
Core: Optimizing for 2 64-bit processors
OpenUO Error: Client files not found.
Scripts: Compiling C# scripts...Failed with: 19 errors, 20 warnings
Errors:
+ Commands/Docs.cs:
CS0246: Line 1175: The type or namespace name 'PowderOfTemperament' could no
t be found (are you missing a using directive or an assembly reference?)
CS0246: Line 1198: The type or namespace name 'AncientSmithyHammer' could no
t be found (are you missing a using directive or an assembly reference?)
CS0246: Line 1200: The type or namespace name 'AncientSmithyHammer' could no
t be found (are you missing a using directive or an assembly reference?)
CS0246: Line 1200: The type or namespace name 'AncientSmithyHammer' could no
t be found (are you missing a using directive or an assembly reference?)
+ Items/Clothing/BaseClothing.cs:
CS1061: Line 924: 'Server.AosAttributes' does not contain a definition for '
Brittle' and no extension method 'Brittle' accepting a first argument of type 'S
erver.AosAttributes' could be found (are you missing a using directive or an ass
embly reference?)
CS1061: Line 927: 'Server.AosAttributes' does not contain a definition for '
NoRepairs' and no extension method 'NoRepairs' accepting a first argument of typ
e 'Server.AosAttributes' could be found (are you missing a using directive or an
assembly reference?)
+ Items/Armor/BaseArmor.cs:
CS1061: Line 2261: 'Server.AosAttributes' does not contain a definition for
'Brittle' and no extension method 'Brittle' accepting a first argument of type '
Server.AosAttributes' could be found (are you missing a using directive or an as
sembly reference?)
CS1061: Line 2264: 'Server.AosAttributes' does not contain a definition for
'NoRepairs' and no extension method 'NoRepairs' accepting a first argument of ty
pe 'Server.AosAttributes' could be found (are you missing a using directive or a
n assembly reference?)
+ Items/Weapons/BaseWeapon.cs:
CS1061: Line 4324: 'Server.AosAttributes' does not contain a definition for
'Brittle' and no extension method 'Brittle' accepting a first argument of type '
Server.AosAttributes' could be found (are you missing a using directive or an as
sembly reference?)
CS1061: Line 4327: 'Server.AosAttributes' does not contain a definition for
'NoRepairs' and no extension method 'NoRepairs' accepting a first argument of ty
pe 'Server.AosAttributes' could be found (are you missing a using directive or a
n assembly reference?)
+ Items/Jewels/BaseJewel.cs:
CS1061: Line 546: 'Server.AosAttributes' does not contain a definition for '
Brittle' and no extension method 'Brittle' accepting a first argument of type 'S
erver.AosAttributes' could be found (are you missing a using directive or an ass
embly reference?)
CS1061: Line 549: 'Server.AosAttributes' does not contain a definition for '
NoRepairs' and no extension method 'NoRepairs' accepting a first argument of typ
e 'Server.AosAttributes' could be found (are you missing a using directive or an
assembly reference?)
+ Items/- BaseClasses/BaseTool.cs:
CS0246: Line 141: The type or namespace name 'AncientSmithyHammer' could not
be found (are you missing a using directive or an assembly reference?)
CS0246: Line 146: The type or namespace name 'AncientSmithyHammer' could not
be found (are you missing a using directive or an assembly reference?)
+ Custom/New/Lumberjacking Prospectors Tool.cs:
CS1061: Line 102: 'Server.Engines.Harvest.HarvestVein' does not contain a de
finition for 'IsProspected' and no extension method 'IsProspected' accepting a f
irst argument of type 'Server.Engines.Harvest.HarvestVein' could be found (are y
ou missing a using directive or an assembly reference?)
CS1061: Line 149: 'Server.Engines.Harvest.HarvestVein' does not contain a de
finition for 'IsProspected' and no extension method 'IsProspected' accepting a f
irst argument of type 'Server.Engines.Harvest.HarvestVein' could be found (are y
ou missing a using directive or an assembly reference?)
+ Custom/Universal Storage Keys/Items/SmithyKey.cs:
CS0246: Line 23: The type or namespace name 'PowderOfTemperament' could not
be found (are you missing a using directive or an assembly reference?)
+ Custom/Universal Storage Keys/Main Data Management/StoreEntries.cs:
CS0246: Line 1661: The type or namespace name 'AncientSmithyHammer' could no
t be found (are you missing a using directive or an assembly reference?)
CS0246: Line 1687: The type or namespace name 'AncientSmithyHammer' could no
t be found (are you missing a using directive or an assembly reference?)
CS0246: Line 1692: The type or namespace name 'AncientSmithyHammer' could no
t be found (are you missing a using directive or an assembly reference?)
CS0246: Line 1692: The type or namespace name 'AncientSmithyHammer' could no
t be found (are you missing a using directive or an assembly reference?)
CS0246: Line 1716: The type or namespace name 'AncientSmithyHammer' could no
t be found (are you missing a using directive or an assembly reference?)
CS0246: Line 1716: The type or namespace name 'AncientSmithyHammer' could no
t be found (are you missing a using directive or an assembly reference?)
CS0246: Line 1757: The type or namespace name 'AncientSmithyHammer' could no
t be found (are you missing a using directive or an assembly reference?)
CS0246: Line 1762: The type or namespace name 'AncientSmithyHammer' could no
t be found (are you missing a using directive or an assembly reference?)
+ Items/Skill Items/Harvest Tools/ProspectorsTool.cs:
CS1061: Line 176: 'Server.Engines.Harvest.HarvestVein' does not contain a de
finition for 'IsProspected' and no extension method 'IsProspected' accepting a f
irst argument of type 'Server.Engines.Harvest.HarvestVein' could be found (are y
ou missing a using directive or an assembly reference?)
CS1061: Line 228: 'Server.Engines.Harvest.HarvestVein' does not contain a de
finition for 'IsProspected' and no extension method 'IsProspected' accepting a f
irst argument of type 'Server.Engines.Harvest.HarvestVein' could be found (are y
ou missing a using directive or an assembly reference?)
+ Items/Skill Items/Tools/RunicSewingKit.cs:
CS0246: Line 93: The type or namespace name 'SpinedRunicSewingKit' could not
be found (are you missing a using directive or an assembly reference?)
CS0246: Line 95: The type or namespace name 'HornedRunicSewingKit' could not
be found (are you missing a using directive or an assembly reference?)
CS0246: Line 97: The type or namespace name 'BarbedRunicSewingKit' could not
be found (are you missing a using directive or an assembly reference?)
CS0246: Line 99: The type or namespace name 'PolarRunicSewingKit' could not
be found (are you missing a using directive or an assembly reference?)
CS0246: Line 101: The type or namespace name 'SyntheticRunicSewingKit' could
not be found (are you missing a using directive or an assembly reference?)
CS0246: Line 103: The type or namespace name 'BlazeRunicSewingKit' could not
be found (are you missing a using directive or an assembly reference?)
CS0246: Line 105: The type or namespace name 'DaemonicRunicSewingKit' could
not be found (are you missing a using directive or an assembly reference?)
CS0246: Line 107: The type or namespace name 'ShadowRunicSewingKit' could no
t be found (are you missing a using directive or an assembly reference?)
CS0246: Line 109: The type or namespace name 'FrostRunicSewingKit' could not
be found (are you missing a using directive or an assembly reference?)
CS0246: Line 111: The type or namespace name 'EtherealRunicSewingKit' could
not be found (are you missing a using directive or an assembly reference?)
+ Quests/New Haven/GeorgeHephaestus.cs:
CS0246: Line 82: The type or namespace name 'HammerOfHephaestus' could not b
e found (are you missing a using directive or an assembly reference?)
+ Services/BulkOrders/Rewards.cs:
CS0118: Line 355: 'Server.Engines.BulkOrders.SmithRewardCalculator.PowderOfT
emperament' is a 'field' but is used like a 'type'
CS0246: Line 384: The type or namespace name 'AncientSmithyHammer' could not
be found (are you missing a using directive or an assembly reference?)
+ Services/Craft/Core/CraftGump.cs:
CS0103: Line 767: The name 'Enhance' does not exist in the current context
+ Services/Craft/Core/CraftItem.cs:
CS0246: Line 1395: The type or namespace name 'AncientSmithyHammer' could no
t be found (are you missing a using directive or an assembly reference?)
CS0246: Line 1395: The type or namespace name 'AncientSmithyHammer' could no
t be found (are you missing a using directive or an assembly reference?)
CS0246: Line 1399: The type or namespace name 'HammerOfHephaestus' could not
be found (are you missing a using directive or an assembly reference?)
CS0246: Line 1419: The type or namespace name 'HammerOfHephaestus' could not
be found (are you missing a using directive or an assembly reference?)
+ Services/Quests/Mondain's Legacy/BaseReward.cs:
CS0246: Line 135: The type or namespace name 'RunicFletcherTool' could not b
e found (are you missing a using directive or an assembly reference?)
CS0246: Line 137: The type or namespace name 'RunicFletcherTool' could not b
e found (are you missing a using directive or an assembly reference?)
CS0246: Line 139: The type or namespace name 'RunicFletcherTool' could not b
e found (are you missing a using directive or an assembly reference?)
CS0246: Line 141: The type or namespace name 'RunicFletcherTool' could not b
e found (are you missing a using directive or an assembly reference?)
+ Services/XmlSpawner 2/XmlEngines/XmlMobFactions/XmlMobFactionsRewards.cs:
CS0246: Line 56: The type or namespace name 'PowderOfTemperament' could not
be found (are you missing a using directive or an assembly reference?)
CS0246: Line 60: The type or namespace name 'AncientSmithyHammer' could not
be found (are you missing a using directive or an assembly reference?)
+ Services/XmlSpawner 2/XmlEngines/XmlPoints/XmlPointsRewards.cs:
CS0246: Line 48: The type or namespace name 'AncientSmithyHammer' could not
be found (are you missing a using directive or an assembly reference?)
CS0246: Line 51: The type or namespace name 'PowderOfTemperament' could not
be found (are you missing a using directive or an assembly reference?)
+ Services/XmlSpawner 2/XmlEngines/XmlQuest/XmlQuestPointsRewards.cs:
CS0246: Line 48: The type or namespace name 'AncientSmithyHammer' could not
be found (are you missing a using directive or an assembly reference?)
CS0246: Line 50: The type or namespace name 'PowderOfTemperament' could not
be found (are you missing a using directive or an assembly reference?)
Scripts: One or more scripts failed to compile or no script files were found.
- Press return to exit, or R to try again.
 
It looks like we are currently having a small issue. I apparently merger Owltr with the version of the core i had merged imbuing into.
So you can either include those scripts as well, or I can at some point in time try a clean merge with no imbuing.
 
I am getting this error (also with boards) while testing:
----------------------------------------------------------------------------
ServUO - [http://www.servuo.com] Version 0.4, Build 5009.11786
Publish 52
Core: Optimizing for 4 64-bit processors
Scripts: Compiling C# scripts...done (cached)
Scripts: Skipping VB.NET Scripts...done (use -vb to enable)
Scripts: Verifying...
Finished (6836 items, 1640 mobiles, 13 customs) (1.96 seconds)
ACC Registered: Server.ACC.CSS.CSS
ACC Registered: Server.ACC.CM.CentralMemory
Regions: Loading...done
World: Loading...An error was encountered while loading a saved object
- Type: Server.Items.Log
- Serial: 0x40000241
Delete the object? (y/n)
After pressing return an exception will be thrown and the server will terminate.
Error:
System.FormatException: Index (zero based) must be greater than or equal to zero and less than the s
ize of the argument list.
at System.Text.StringBuilder.AppendFormat(IFormatProvider provider, String format, Object[] args)
at System.String.Format(IFormatProvider provider, String format, Object[] args)
at Server.World.Load() in e:\RDUO\Server\World.cs:line 656
at Server.Core.Main(String[] args) in e:\RDUO\Server\Main.cs:line 648
This exception is fatal, press return to exit
 
@Redmoon I too get the load error on logs and on boards, even after including the daat99 in both files.
It seems I have screwed up some where, if some one can help me track down the fix I will be glad to re-implement it.


Also there appears to be an issue with Large weapon bods returning a badd index value, I will work on adding a check for this so as it does not crash servers.
 
Wow! Thank you for such a quick response! I'll install these and let you know if it works. :D[DOUBLEPOST=1379513315,1379512454][/DOUBLEPOST]- Type: Server.Items.Log
- Serial: 0x40017990
Delete the object? (y/n)

and

- Type: Server.Items.Board
- Serial: 0x4001798E
Delete the object? (y/n)

Serial #s changed, but same error. :(
 
Well...boards still giving me a problem...but logs OK.
@Redmoon

Weird I had typed a whole reply and it did not post it.
Any way to recap: Only change you made that would effect loading, imo, is the serialization change, which I already added in the last update to this resource.

As for line 152
Code:
if (!TryCreateBoards(from, 95, new Board()))
this makes it so players cannot even create a normal board until 95 skill in lumberjacking, I changed it to 0 and this seems to work more as expected.

You also commented out the DefaultResource, which I left in because it was part of ServUO. Any reason you commented those out?
 
Boards fixed! I'm bound and determined to have my old server back...:D
 

Attachments

  • Board.cs
    11.8 KB · Views: 20
  • aimg.photobucket.com_albums_v387_otimpyre_Preview_1.png
    aimg.photobucket.com_albums_v387_otimpyre_Preview_1.png
    84.3 KB · Views: 203
No..Thank YOU! You did most of the work! *high five*
 

Attachments

  • aimg.photobucket.com_albums_v387_otimpyre_RunUO_20Graphics_HTown_Fountain.png
    aimg.photobucket.com_albums_v387_otimpyre_RunUO_20Graphics_HTown_Fountain.png
    9.3 KB · Views: 287
  • aimg.photobucket.com_albums_v387_otimpyre_RunUO_20Graphics_NBC_Jack_praise.jpg
    aimg.photobucket.com_albums_v387_otimpyre_RunUO_20Graphics_NBC_Jack_praise.jpg
    28.1 KB · Views: 200
A
No..Thank YOU! You did most of the work! *high five*
any more errors let me know and we can try to figure them out!

Some of them have been pretty difficult like the bod crash one, but it seems like we are making some progress!
 

Attachments

  • aimg.photobucket.com_albums_v387_otimpyre_RunUO_20Graphics_Bobble_20Heads.png
    aimg.photobucket.com_albums_v387_otimpyre_RunUO_20Graphics_Bobble_20Heads.png
    13.9 KB · Views: 214
I haven't tested the BODs yet, I'll test it next.

What is the BOD crash? Is it getting them or turning them in?
 

Attachments

  • aimg.photobucket.com_albums_v387_otimpyre_RunUO_20Graphics_Chains_20of_20Torment.png
    aimg.photobucket.com_albums_v387_otimpyre_RunUO_20Graphics_Chains_20of_20Torment.png
    6.9 KB · Views: 237
I haven't tested the BODs yet, I'll test it next.

What is the BOD crash? Is it getting them or turning them in?
Apparently some where in the OWLTR system there is something amiss with the Large bods. Apparently Large weapon bods return 15 and 16 instead of 13 and 14, which causes a NullExcpetion error because the array is out of bounds. I have added a check to see if the index returned is larger than the bounds of the array and if it is to shrink that back down to the max bounds of the array.
 

Attachments

  • aimg.photobucket.com_albums_v387_otimpyre_RunUO_20Graphics_Caged.png
    aimg.photobucket.com_albums_v387_otimpyre_RunUO_20Graphics_Caged.png
    33.5 KB · Views: 193
I guess I need to add a spawner and get a large weapon bod then.
if you haven't already loaded the spawns and decorated the world then yes. But I can tell you with some certainty that the large smith bods at least no longer crash the server.
 
I added a xmlspawner with LargeSmithBOD, I have a Large exp 20 Axe bod. Is it suppose to crash when turned in? I'm gonna fill this one and see what happens.
 
I added a xmlspawner with LargeSmithBOD, I have a Large exp 20 Axe bod. Is it suppose to crash when turned in? I'm gonna fill this one and see what happens.


No no, it used to crash with a large bod turn in, when it tried to calculate the gold it would return an invalid index for an array.
it should be 'fixed' now. at least so that it does not crash
 

Attachments

  • aimg.photobucket.com_albums_v387_otimpyre_RunUO_20Graphics_Holes.png
    aimg.photobucket.com_albums_v387_otimpyre_RunUO_20Graphics_Holes.png
    5.8 KB · Views: 150
Ah, ok..sorry I'm about brain-dead from scripting. :oops:
 

Attachments

  • aimage.prntscr.com_image_db82a9cbc72e42a4a34d42a240777225.png
    aimage.prntscr.com_image_db82a9cbc72e42a4a34d42a240777225.png
    5.7 KB · Views: 515
Ah, ok..sorry I'm about brain-dead from scripting. :oops:
It's understandable! I get pretty fried after a long day of staring at code.

Just go play with the system and make sure it works for you!
 

Attachments

  • aimage.prntscr.com_image_a0dcedfd0fbb499cb5ebcf8ea64162c8.png
    aimage.prntscr.com_image_a0dcedfd0fbb499cb5ebcf8ea64162c8.png
    37.3 KB · Views: 595
  • aimage.prntscr.com_image_c8f5669b30b94a5f97399fabe69190a2.png
    aimage.prntscr.com_image_c8f5669b30b94a5f97399fabe69190a2.png
    26.7 KB · Views: 590
  • aimage.prntscr.com_image_faf47c92e0e44ff7a9c597e962ce3634.png
    aimage.prntscr.com_image_faf47c92e0e44ff7a9c597e962ce3634.png
    149.4 KB · Views: 594
Thank you again! I'm done, unless other errors/crashes pop up..and waiting for old FSAT to be here.
 

Attachments

  • aimage.prntscr.com_image_83d3d7c9afbf4fecad6f1902a20a62c5.png
    aimage.prntscr.com_image_83d3d7c9afbf4fecad6f1902a20a62c5.png
    14 KB · Views: 606
any more errors let me know and we can try to figure them out!

Hello! Tried to install this fresh from your fork on bitbucket, and got the following result during compile... I am a total noob at the whole thing, so I might be missing something pretty straight forward. Thanks in advance for any help you can provide in setting me straight...

[fieldset=Compile Errors]Failed with: 2 errors, 0 warnings
Errors:
+ Items/Skill Items/Carpenter Items/Board.cs:
CS0246: Line 2: The type or namespace name 'daat99' could not be found (are
you missing a using directive or an assembly reference?)
+ Items/Skill Items/Lumberjack/Log.cs:
CS0246: Line 2: The type or namespace name 'daat99' could not be found (are
you missing a using directive or an assembly reference?)
Scripts: One or more scripts failed to compile or no script files were found.
- Press return to exit, or R to try again.[/fieldset]

**Edit: Was able to get it to compile by commenting out the "using daat99" entries in Log.cs and Boards.cs, but not sure what's up - tried that last night and gave me a rash of errors - today, compiled right up.
 
Last edited:
@Gold Matterson I added those to try and fix an issue, I forgot to take them back out. I will update the download with the removed using statements.
Let me know how it goes for you!
 
@Gold Matterson I added those to try and fix an issue, I forgot to take them back out. I will update the download with the removed using statements.
Let me know how it goes for you!

@sec_goat, I must be doing something wrong here, or missing something entirely. Pulled down your fork as mentioned previously, got it to compile, etc, and am running the server locally on my machine. When I try to "[add daat99owltr" to set up the OWLTR portion, it says that it is not a valid command. Do I still need to add portions of the OWLTR script set to my server files? I thought by DL'ing your particular fork that all of it was already integrated into the custom systems, etc.

Any help for this noob would be greatly appreciated! :)
 
@Gold Matterson interesting, I have not tried to spawn that particular item as I have left everything as default.
I am unable to test until later today, but have you tried a
[add daat
and see if any items come up in the search?

Also Make sure \Custom Systems\OWLTR 3.01.00\New\Daat99 OWLTR Control Center.cs
exists.
 
@Gold Matterson
I just tested to see if I could add the [Daat99OWLTR aka the daat99 controller, and I have no problems with it. I'm guessing you are missing something.

This is the file for the controller: Daat99 OWLTR Control Center.cs
 
@Gold Matterson
I just tested to see if I could add the [Daat99OWLTR aka the daat99 controller, and I have no problems with it. I'm guessing you are missing something.

This is the file for the controller: Daat99 OWLTR Control Center.cs

@Redmoon / @sec_goat -
Thanks for the heads-up. I checked and \Custom Systems\OWLTR 3.01.00 folder doesn't exist in the source I pulled down from the servuo\owltr fork on your site. I apologize for the goose chase...wasn't aware it needed to be added separately from the files I pulled down from your bitbucket site. Slowly starting to get the idea here...
 
Ok, I have been working on this for a bit, and realize this is probably mostly my inexperience, but I have added OWLTR 3.01.00 folder to custom systems folder in a fresh download from your bitbucket site. Figured out that the "modified files" are repeats of files already in the download....so I deleted the modified folder assuming these are the files you mentioned you already merged into the system. After this, I get the following errors upon trying to start the server. Hope you might be able to help offer some insight into what the heck I'm doing wrong here...Have I made some incorrect assumptions based on what to do with the modified folder contents?

Thanks in advance for any help!

[fieldset=Errors]Failed with: 5 errors, 0 warnings
Errors:
+ Custom Systems/OWLTR 3.01.00/New/BodRewards/Smithers Protector.cs:
CS0506: Line 55: 'Server.Items.SmithersProtector.OnHit(Server.Mobile, Server
.Mobile)': cannot override inherited member 'Server.Items.BaseWeapon.OnHit(Serve
r.Mobile, Server.Mobile)' because it is not marked virtual, abstract, or overrid
e
+ Custom Systems/OWLTR 3.01.00/New/BodRewards/Tailors Protector.cs:
CS0506: Line 52: 'Server.Items.TailorsProtector.OnHit(Server.Mobile, Server.
Mobile)': cannot override inherited member 'Server.Items.BaseWeapon.OnHit(Server
.Mobile, Server.Mobile)' because it is not marked virtual, abstract, or override

+ Custom Systems/OWLTR 3.01.00/New/RunicFletchersTools.cs:
CS0115: Line 88: 'Server.Items.RunicFletcherTools.GetCraftableType()': no su
itable method found to override
+ Custom Systems/OWLTR 3.01.00/New/RunicTinkerTools.cs:
CS0115: Line 63: 'Server.Items.RunicTinkerTools.GetCraftableType()': no suit
able method found to override
+ Custom Systems/OWLTR 3.01.00/New/Mule.cs:
CS0115: Line 80: 'Server.Mobiles.Mule.OnBeforeTame()': no suitable method fo
und to override
Scripts: One or more scripts failed to compile or no script files were found.
- Press return to exit, or R to try again.
[/fieldset]
 
If you pulled my branch then there should be no modified folder.
if you downloaded the zip from this site, then yes there is a modified folder.
A pull should work, a download of the zip requires some merging, sound like you are trying to do both.

Those items you are having issues with are all new items and don't require any sort of merge, so I am not sure why you are getting those. Try a fresh copy of ServUO and see if you can get that working first?
 
Thanks @sec - I originally pulled a fresh copy of Servuo from your owltr branch to do this change, and the server starts fine, but there is is no OWLTR folder in custom systems. I then downloaded the OWLTR zip from here, and tried to add it to the fresh installation in the custom systems. I deleted the modified folder, but get the above errors.

Am I correct in my understanding that this is how you planned it to be? No OWLTR folder in "custom system" folder in your branch of servuo marked OWLTR?
 
@Gold Matterson No sir. a pull should have the folder, I am looking at it right now on bit bucket and it has the folder.
If you are just pulling a copy of the main branch, then yes it will not have anything in the customs folder as main is just a fork of Servuo if you

git pull origin owltr

you should get every thing you need. I just tried it myself and it works for me.
 
Personally, I use git clone in it's own folder then copy what's needed to my ServUO folder. I think we need a git / svn tutorial. ;)
 
Back