Disconnected

Aporia

Member
Oct 14, 2019
5
2
Hello,
I am completely new to ServUO so I apologies in advance. I have a server going via the Wiki (getting started) and it's worked fine for a few days of light play in the starter area. However, this morning the server started behaving odd by disconnecting the client right after choosing the character the Server window says : Entering world (user name) and then immediately says Disconnected and lists the IP

I have two other clients / characters running for my sons. If one of those logs out, they then will not be able to get back into the server, mimicking the above behavior. So, we can't login to the server.

I tried restoring from save, and that worked okay but it just happened again. Both times i was down in the starter skeleton (Ocllo) area.

Any suggestion, please?
 

fcondon

Member
Sep 13, 2019
8
0
Can anyone log in? The way you describe it, it sounds like it might be a limit issue? There is a setting in the settings that allows you to increase how many people can be logged in from the same IP. However if no one is able to log in this wouldnt be the issue.
 

Milva

Admin
Moderator
Mar 3, 2013
4,319
503
Donate
Donate money to this user
Is the server showing any errors on the window when this happens? Did you check your crash reports to see if there would be on to post the errors if so.
What would your client patch number be at for your client and the server?
 

JGreen

Well-Known Member
Jul 16, 2019
76
14
I have had some what of same problem. where server was running and I get kicked and couldnt log back in. no errors or anything. so i did some searching around and found out it was a bad timer on a custom script caused the hole server to kinda freeze up
 

Falkor

Well-Known Member
Apr 11, 2018
147
50
wpshard.com
Shard Name
Whispering Pines
The PreventInaccess script (in /Services) is supposed to rescue staff characters caught in a client-crashing loop by moving them to a safe area on the third login crash. You can move other characters by editing their logoff location to a similar safe area so when they log in they're not in the bad area.

Now finding and fixing the area that causes the crashing is an entirely different matter!
 

Aporia

Member
Oct 14, 2019
5
2
Hello,

It is not an IP limit as I did change that since were all local within the home.

I don't see errors except for the one I will attach. Inside \Logs I only see a folder for Chat and Commands. But the text files in those don't have any errors.

This morning when I started the server it said there were no accounts and asked if I wanted to create an Admin account. After posting this message yesterday I went to work and didn't play. The server did run while I was away, but evidently something has happened and the characters are all gone now?

What JGreen and Falkor mentioned seems related. When this first occurred the client sort of froze and I couldn't do anything with my character. So, i closed the client and tried reconnecting. But could not get in on any account from that point forward. Then, it happened again after the restore from save. Both in that skeleton Ocllo area.

I do not have anything custom in this server. It is just ServUO and nothing else added.

I am not sure how to even frame a question since the accounts seem to be gone. I guess I just start over again?
 

Attachments

JGreen

Well-Known Member
Jul 16, 2019
76
14
I seen that error pop up on my server too

10/17/2019 1:11:35 AM Warning: Attempted to add 0x400213A9 "KhaldunDecorationAddon" during world save.
This action could cause inconsistent state.
It is strongly advised that the offending scripts be corrected.
at Server.Item..ctor()
at Server.Items.BaseAddon..ctor()
at Server.Items.KhaldunDecorationAddon..ctor()
at Server.Engines.Khaldun.TreasuresOfKhaldunGeneration.GenerateQuestContent()
at Server.Engines.Khaldun.TreasuresOfKhaldunGeneration.CheckEnabled(Boolean timed)
at Server.WorldSaveEventHandler.Invoke(WorldSaveEventArgs e)
at Server.EventSink.InvokeWorldSave(WorldSaveEventArgs e)
at Server.World.Save(Boolean message, Boolean permitBackgroundWrite)
at Server.Timer.DelayCallTimer.OnTick()
at Server.Timer.Slice()
at Server.Core.Main(String[] args)

I turned that system off using the command

and those stopped