Milva submitted a new resource:

Firerock Crafting By Hammerhand - Firerock Crafting,

This was created By Hammerhand
He has given me permission to post this since the old link is broken.
Information on this:
FireRockCrafting ver 3.0
(This has been updated since the last publish date listed below)
Tested on a publish 51 ForkUO/ServUO tester. Players mine in lava for small & large
FireRock & CrystalineFire for crafting the weapons, armor & addon items in this system. Includes weaps & armor for Gargoyles. Anywho, without further annoyance from me, I present...
*Does require 2 small edits to the PlayerMobile.cs, explained in included text sheet*...

Read more about this resource...
Last edited:
So I did run into a problem with this, the crafting part is fine but mining the fire rock fails somehow. When selecting a Lava tile, nothing actually mines, no error no indicating that anything happened. Can't see the reason why this would fail.
Are you using the fire pickaxe that is purchased from the vendor? I am using this system currently and it works fine, though not all lava tiles can be mined. Only issue I know of is that you cannot unstack the fire rock, so breaking them down into smaller piles is not an option and if you mine a large amount you can run into an issue with not being able to get them into your pack.

Forgot to mention my client is patched up to the latest client 7.0.52 I believe it is.
Hmm im using, when it fails for you on tiles it doesn't mine, do you get an error or does it do nothing? I use the firepick generated by the add menu, not buying it. Yeah I suspect the lava tile list may need to be updated.
Tried patching up, didn't fix the problem, also tried manually adding the tile from the tile list in the mining script , and that did not work as well. just in case I downloaded a new mining script from the zip file and copied it over, as well as the fire pick, no change :(
On some lava tiles I get nothing, on others it will go thru the mining animation but a message is generated to the effect that there is no fire rock to be mined.
i wonder if the mining script needs to be updated, when comparing against the current mining script (though i know there should be a vast difference) some parts seem dated.
It's a long shot, but I had a player that had this issue today...the fix was he hadn't purchased the Fire Rock Mining book from the vendor and learned it. If you haven't purchased the book, buy the book from the vendor that sells the other items and double click it, you should then be able to mine the Fire Rock.
I just added this to a new ServUO Master & it works fine. FireRock was minable. Did you add in the Enum & PlayerFlags in PlayerMobile.cs? The current number you need to follow in the Enums is
ToggleCutTopiaries = 0x10000000
which means you need to add the FireRockMining as
        ToggleCutTopiaries = 0x10000000, // Add the , at the end of this line
        FireRockMining = 0x20000000
Then add the PlayerFlags and save.
        public bool HasStatReward { get { return GetFlag(PlayerFlag.HasStatReward); } set { SetFlag(PlayerFlag.HasStatReward, value); } }
        public bool FireRockMining
            get { return GetFlag(PlayerFlag.FireRockMining); }
            set { SetFlag(PlayerFlag.FireRockMining, value); }
Its easy to make the FireRocks unstackable if that is what you want. They dont separate because the rock art doesnt have a stackable. Just go into the FireRock.cs script & comment this out.
Stackable = true;
or change the true to false. Do this for each type. Small, Large & CrystalineFire
In Enums add FireRockMining = 0x06000000 // Or whatever is the next available number.
If you look at the numbers in Enums, they double for each entry, so you need to double the last number listed.
New FireRock & CrystalineFire art that allows the player to seperate them like ingots & boards. Should make things much easier. ScreenHunter_191 Jan. 04 09.43.jpgScreenHunter_192 Jan. 04 09.43.jpgScreenHunter_193 Jan. 04 09.44.jpg


  • CrystalineFire.cs
    1,012 bytes · Views: 14
  • FireRock.cs
    2.1 KB · Views: 13
Oh that is nice, yeah I did not like the clunky look of the resource. I will try it tonight and report any problems :) thank you!
Didnt exactly have those when I first made it (I dont think). Tested them & all seem to seperate just fine (at least for me). ;) I def like the scale art for the firerock.. looks all bubbly & crusty, like lava should after cooling a bit. lol
Hey Hammerhand,

I tried out the lava crafting system and everything seems to work except when I go to a lava pool and use the pick my character just stands there and doesn't do anything??
Hmmm no good. Worse.

Crash Report:

+ Customs/[]-FireRockCraftVer 3.0/FireRockCraftVer 3.0 ServUO/FireRockMining.cs:
CS1061: Line 63: 'Server.Engines.Harvest.HarvestDefinition' does not contain a definition for 'ConsumedPerIlshenarHarvest' and no extension method 'ConsumedPerIlshenarHarvest' accepting a first argument of type 'Server.Engines.Harvest.HarvestDefinition' could be found (are you missing a using directive or an assembly reference?)
CS1061: Line 64: 'Server.Engines.Harvest.HarvestDefinition' does not contain a definition for 'ConsumedPerTerMurHarvest' and no extension method 'ConsumedPerTerMurHarvest' accepting a first argument of type 'Server.Engines.Harvest.HarvestDefinition' could be found (are you missing a using directive or an assembly reference?)
Scripts: One or more scripts failed to compile or no script files were found.
- Press return to exit, or R to try again.