Megacliloc Error

Jun 7, 2019
5
0
Good Day All,

First post here!

So I'm using Client 7.0.20.0 (I think). Different installs of it are being used for ServUO and for my player client (with Razor).

When I login I get these problems:

13675

13676

I read a previous thread:


It's described here as part of not having a properly updated client. But I can't understand why it's an issue since both my Server and Razor are using the same version (Generally in separate installs).

Does anyone have any suggestions besides using the newest OSI patch (which, I gather, we wouldn't want players on a future shard to do?)

Thank you so much.
Vas
 
Jun 7, 2019
5
0
Thank you very much.

If you wouldn't mind...

I'm looking at CurrentExpansion.cs, which lines do I alter to set it as High Seas?
Post automatically merged:

I tried to edit Expansion.cfg but that didn't help.
Post automatically merged:

Actually, even changing it to CurrentExpansion=UOR didn't seem to change anything..
 
Last edited:

Grimoric

Well-Known Member
Mar 21, 2015
174
40
43
This is happening sins the client you have don't have the latest features. The developers have not added a switch for features to support the expansion flag system from RunUO. You have to fix this by yourself by either code your server as you like by adding a switch or just remove the new things they added.

The error line under "Open backpack" is a text that should open a "Vendor search" feature and this didn't exist in 7.0.20.0 client and all older but your server is still sending you're the request for showing this information and failed sins client have no clue what it is.

The development has been made by installing the latest client and ignoring all changes that impact older clients. You will find these issues a lot all over the code if you choose an older era.

-Grim
 
Last edited:
  • Like
Reactions: vasinjuxhurylem
Jun 7, 2019
5
0
Thank you very much for your insight. The thing I don't get though is, why am I getting these even though the play client and server client are both the same patch?
 

Grimoric

Well-Known Member
Mar 21, 2015
174
40
43
What is your expansion set to? is it still HS? in this case it is a (Core.HS && Alive) in the code.
 
Jun 7, 2019
5
0
Originally it was set to Enchanted Journey but I tried setting it to HS and even to UOR in Expansion.cfg. I didn't know how to properly modify CurrentExpansion.cs though so I didn't try that much.

Basically the goal is High Seas.
 

Grimoric

Well-Known Member
Mar 21, 2015
174
40
43
Check CurrentExpansion.cs in Script/Misc and set it to this (should help on the way).

public static readonly Expansion Expansion = Config.GetEnum("Expansion.CurrentExpansion", Expansion.UOR);
 
Last edited:
Jun 7, 2019
5
0
Excellent, thank you, I'll try it right now.
Post automatically merged:

Unfortunately it's still showing me the error, though I changed CurrentExpansion.cs as you suggested and Expansion.cfg to UOR as well.

Here's what CurrentExpansion.cs looks like now:

#region References
using System;

using Server.Accounting;
using Server.Network;
using Server.Services.TownCryer;
#endregion

namespace Server
{
public class CurrentExpansion
{
public static readonly Expansion Expansion = Config.GetEnum("Expansion.CurrentExpansion", Expansion.UOR);

[CallPriority(Int32.MinValue)]
public static void Configure()
{
Core.Expansion = Expansion;

AccountGold.Enabled = Core.TOL;
AccountGold.ConvertOnBank = true;
AccountGold.ConvertOnTrade = false;
VirtualCheck.UseEditGump = true;

TownCryerSystem.Enabled = Core.TOL;

ObjectPropertyList.Enabled = Core.AOS;

Mobile.InsuranceEnabled = Core.AOS && !Siege.SiegeShard;
Mobile.VisibleDamageType = Core.AOS ? VisibleDamageType.Related : VisibleDamageType.None;
Mobile.GuildClickMessage = !Core.AOS;
Mobile.AsciiClickMessage = !Core.AOS;

if (!Core.AOS)
{
return;
}

AOS.DisableStatInfluences();

if (ObjectPropertyList.Enabled)
{
PacketHandlers.SingleClickProps = true; // single click for everything is overriden to check object property list
}

Mobile.ActionDelay = Core.TOL ? 500 : Core.AOS ? 1000 : 500;
Mobile.AOSStatusHandler = AOS.GetStatus;
}
}
}
 
Last edited:

Grimoric

Well-Known Member
Mar 21, 2015
174
40
43
This was resolved (in conversation) it was a file name issue and the rest of the CliLoc id issues (like 1152913) need to be fixed by hand.

-Grim
 
  • Like
Reactions: vasinjuxhurylem