Not sure where to post this

AllisonUO

Citizen
Hello everyone! I just created a new server and have a few questions:
1) Is there a way to configure what a new character starts with? Gold, items, skills, stats etc. or is it just what is defaulted from the original game?
2) Is there a way to change a character's stats, items etc. for an Administrator (or any character for that matter)? I would like my Administrator to not die everywhere!
3) Is there a way for an Administrator to summon a monster or character to her current location?
4) Is all customization for houses the same as the current game or can you make a 20 X 20 house or increase the storage of a house?
5) Is there a way to increase the cap limits on stats, skills, max number of skill points etc?

That's it for now. Thanks for looking!
 

PyrO

Moderator
1) its in CharacterCreation.cs, you can change whatever you want as starting gear
2) either you can use [props and click on the mobiles, or do [set str 10000 or whatever you like
3) "summoning" creatures would be [add dragon <- for example. To fetch players? The easiest way is to use the [admin command
4) By default it is like OSI, you can adjust that yourself inside the HousePlacementTool.cs, in the HousePlacementEntry class
5) inside the Config folder is a PlayerCaps.cfg
 

AllisonUO

Citizen
Thanks for the info! I thought I could only change things in the config folder. A few more things:
1) On my new server I only see Trammel and Fel. How do I see the other areas (Malas, Tokuno, Ter Mur etc.)?
2) This may be more advanced but where can I find info on specialized customization? I have see other servers with different monsters/pet. Dragons can be mounted etc. Also houses can have cellars. Davie's locker can sort maps. Many other customizations.
Post automatically merged:


Post automatically merged:

Another issue is I can't get my pet to attack a troll/monster.

Also now that I am playing with the settings to customize the server, I forgot everything I did.
How do I start over or reset everything to the default?
Do I need to download some files again?
 
Last edited:

DragnMaw

Citizen
1) Where are you looking, and did you do the [createworld command on your server? It should have created the moongates with all the worlds by default.
2) If you check resources here you can find some, but they might not be intended for whichever version of ServUO you are running. A lot of things like that are coded in by the staff, and not always released.
 

AllisonUO

Citizen
I did [createworld. I am in a moongate looking to get to those other areas.
Post automatically merged:

Logging out and back in worked. Thanks!

Still have issues with pets. Claiming, kill command etc.
 
Last edited:

DragnMaw

Citizen
Which version did you download of ServUO? The most recent?


Theres the guide I had used when I first setup my server. Following those instructions will give you a clean copy.
 

DragnMaw

Citizen
Then you should just be able to delete your current server, and reexact the ServUO-Master.zip I think its called, and that will be a clean install. Double check all Configs before you start the server the first time. If you want Allison, you can talk to me on Discord. Usually a bit quicker than this. DragnMaw#5517
 

DragnMaw

Citizen
By default, new IP address's can create an account, just by typing in a username and password. Somewhere in the configs there would have been a limit on the number of accounts per IP addresses.
 

AllisonUO

Citizen
Thanks I found that. Since the other users are using their own laptops, what do they need to download to access my server?
 

DragnMaw

Citizen
They will need to download Ultima Online Client, and a way to interface with your server. Most commonly used are Razor, UOSteam, and AssistUO I think it is called. Once they download Ultima Online, they need to run it at least once to get the newest patch. After that they launch whichever program they decided to use to connect, type in the IP Address and Port of your server, and hit connect.
 

AllisonUO

Citizen
Is there a way to change the spawn rate on monsters. I killed a balron and it took over 5 minutes to respawn a new one. Thanks.
 

DragnMaw

Citizen
Default spawn rate was/is, 3 min minimum 5 min maximum for most mobs. Prior to using [createworld, you can modify the .xml files in UO\Spawns\*.xml
and then I did a
Replace <MinDelay>3</MinDelay> to <MinDelay>1</MinDelay>
Replace <MaxDelay>5</MaxDelay> to <MaxDelay>3</MinDelay>

Then you will have to regenerate every single spawner (easier just run [XmlSpawnerWipeAll, then redo [createworld. At least thats how I increased the spawn time on my server if my memory serves)

Make sure to double check that MaxDelay default is 5, and MinDelay default is 3 before doing youre replacements, just encase I have the wrong Default Numbers there (going off memory of what they WERE)
 

AllisonUO

Citizen
Thanks. So I need to [create world again. Will this erase everything I've already setup?
Post automatically merged:

I only changed 3 spawns. Can I just regenerate those monsters? If so how di I do that. Thanks again!
 

DragnMaw

Citizen
It will regenerate the same things it did on your original createworld. Its just one of the fastest ways I know to do this. The other option is you could then [xmlimportspawners <each spawner.xml file>
one at a time.

OR!!! (When I did this it ended up working, but caused a server crash)

[xmlspawnersaveall <filename>.xml

then do your replaces on <filename>.xml

then do the [xmlspawnerwipeall

[xmlimportspawners <filename>.xml

Edit - Oh it wasn't [createworld a second time, but [recreateworld
But yeah it regens everything. Decos, Spawners, NPCs, Moongates, etc, etc.
 
Last edited:

AllisonUO

Citizen
Dang. Now all my spawn is gone and [createworld does not appear to do anything!.
I was so close to finally having a server too. :sigh:
 

DragnMaw

Citizen
Do [recreateworld I added it in an edit. You can only do createworld once, recreate does a delete/recreate function, which is nearly the same.
 

AllisonUO

Citizen
Thanks, tried that. Still no spawn/npc's.
Post automatically merged:

There has got to be something simple that I am missing. I did [XmlSpawnerWipeAll, then [recreateworld but no spawn or NPC's show up.
Any suggestions would be appreciated.
 
Last edited: