1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ServUO and SmoothMultis (Publish 54) by nibbio

Discussion in 'Script Support' started by Regnak, Nov 17, 2013.

  1. Regnak
    Offline

    Regnak Active Member

    Joined:
    Apr 1, 2013
    Messages:
    254
    Likes Received:
    43
    Hello guys and girls !

    As it seems the UO Archive is broken, I'll post it here (it can be moved later I guess. Or I'll just re-post this in the archive when it works).

    This post is about getting SmoothMultis work on ServUO Publish 54.

    But what is it ? What are we talking about ?

    Well, this is Smooth Movement and Mouse Control for your Boats and Galleons (Multis). :D

    Be careful, though, if you want to try this as it requires Core modification.

    To install this, on a fresh ServUO Publish 54, just copy/paste and replaced the files that need to be replace. After this, don't forget to recompile.

    For more advanced installations, I've put a TXT file inside with all the files that needs to be merged (and where).

    Hopefully you get it working fine. I actually could make it work ... and this is FUN ! :D

    I've already found some minor bugs, but I wanted it to go public for more intensive testing. So please, play and break the new Galleons so we can try and fix them :)

    A last point, the credits for this script go to nibbio. I didn't do much except making it work on ServUO Publish 54. He's a great scripter ! So please, test this out and help us making it even better :)

    Enjoy !

    -Regnak-
     

    Attached Files:

    • Like Like x 5
    • Agree Agree x 1
  2. Milva
    Offline

    Admin Moderator

    Joined:
    Mar 3, 2013
    Messages:
    3,604
    Likes Received:
    396
    Nice!!! Thanks for sharing so that other's may test this out :) Yes once the Resource area is fixed then this could be moved over with this one removed after.
     
  3. Xen
    Offline

    Xen Member

    Joined:
    Mar 10, 2013
    Messages:
    73
    Likes Received:
    5
    does servuo staff want to add it to the next release?

    however thanks for sharing!!!
     
  4. Milva
    Offline

    Admin Moderator

    Joined:
    Mar 3, 2013
    Messages:
    3,604
    Likes Received:
    396
    I would think this needs feed back from testing before it goes to publish :)
     
  5. Xen
    Offline

    Xen Member

    Joined:
    Mar 10, 2013
    Messages:
    73
    Likes Received:
    5
    ok, right. Who is testing it?
     
  6. cmileto
    Offline

    cmileto Member

    Joined:
    Nov 18, 2013
    Messages:
    176
    Likes Received:
    9
    We have it on our server. Working on clients computer after finishing my truck's universal joint repair so Im busy until later, however, Ill take afew hours later tonight and focus on putting it thru the paces.
     
    • Like Like x 1
  7. Xen
    Offline

    Xen Member

    Joined:
    Mar 10, 2013
    Messages:
    73
    Likes Received:
    5
    i'm craving your answer ;). I hope this mod will work ;).
     
  8. cmileto
    Offline

    cmileto Member

    Joined:
    Nov 18, 2013
    Messages:
    176
    Likes Received:
    9
    Its been installed for awhile with no issues. Im back home so will spawn some boats :p

    Alright, boats out, anchor is raised, what do I do now? lol. Feeling dumb. I cant find my txt file on this system. How do i initiate the mouse control of boat steering?
     
    #8 cmileto, Nov 30, 2013
    Last edited: Dec 1, 2013
  9. Regnak
    Offline

    Regnak Active Member

    Joined:
    Apr 1, 2013
    Messages:
    254
    Likes Received:
    43
    Just double click the wheel ;)

    Also, it does not work with the normal boats. You have to spawn the "new" boats.

    Thx for testing
     
  10. Xen
    Offline

    Xen Member

    Joined:
    Mar 10, 2013
    Messages:
    73
    Likes Received:
    5
    how long should we work to make it working even with the old boats?
     
  11. cmileto
    Offline

    cmileto Member

    Joined:
    Nov 18, 2013
    Messages:
    176
    Likes Received:
    9
    I have tried with britain galleon after adding one with [add galleon
    I cannot move or walk when on the boat and the wheel does nothing.
    I may be doing something wrong. How does one normally get one of these ships (without [add)
     
  12. Regnak
    Offline

    Regnak Active Member

    Joined:
    Apr 1, 2013
    Messages:
    254
    Likes Received:
    43
    @Xen : It should not be hard as there is a newsmallboat class that could be merged or could replace the old one.

    @cmileto : There is no deeds yet, but it should not be hard to include them.
    To start moving, did you try to say 'raise anchor' (even if there is no tillerman) ?
    If yes, I should check the files again.
    Does it move when you say : forward, back, etc ?
     
  13. cmileto
    Offline

    cmileto Member

    Joined:
    Nov 18, 2013
    Messages:
    176
    Likes Received:
    9
    i said raise anchor and nothing happens when im on the galleon. clicking the wheel doesnt seem to do anything at all. Noone can move at all when on the galleon. once off the galleon whatever charcter was previously standing on it can no longer walk/run or move. There doesnt seem to be anyway to fix that (relogging doesnt help). How can I unfreeze them? Or is it time to delete those characters now? [props on the charcter shows cantwalk as being false...

    your welcome to log in on my shard and test if it will help out

    I really want to help make this work and not have to remove it from our shard. Is anyone willing to meet me in game on our shard and test this out more?
    --- Double Post Merged, Dec 1, 2013, Original Post Date: Dec 1, 2013 ---
    Normal boats still seem to work as they always have and do not seem to affect the players movement either on or off them like the galleon did when i tried it. Ended up having to delete and recreate the charcter, nothing i tried would allow thme to walk again and nothing looked wrong at a glance of [props. No worries though as Im using a backup copy of our shard to test this on


    as an update after trying again.
    When unable to move after getting the same results a second time I saved the server and restarted it. Upon relogging in after this server restart the charcter can once again move as normal.
     
    #13 cmileto, Dec 1, 2013
    Last edited: Dec 1, 2013
  14. Regnak
    Offline

    Regnak Active Member

    Joined:
    Apr 1, 2013
    Messages:
    254
    Likes Received:
    43
    I didn't experience that kind of problem. I'll connect to your shard with a character named Regnak.

    Some questions to try to find the problem :
    - what client version do you use (server/client) ?
    - did you merge or just copy paste the core files ?
    - did it throw any warnings/errors while compiling ?
    - I guess you recompiled the core, but we never know : did you compile ServUO after applying the files ?

    Meet ya in game ;)

    If you want and come to test it out on my shard, feel free too :)

    -Rek-
     
  15. cmileto
    Offline

    cmileto Member

    Joined:
    Nov 18, 2013
    Messages:
    176
    Likes Received:
    9
    I merged the files into servuo 54. a few warnings when compiled but no errors.
    client we use is 7.0.23.1 (custom map, but only on felucca. you will start in a custom area too so prob need our client). You can see our websvn and get client,ect on http://wvgeeks.com use that for ip also wvgeeks.com

    I was out of the house a min but ill be on now for rest of evening.

    Could I be doing something wrong? How would I connect to your shard to see it in action? Do you use googletalk? if it helps you can text me @ 3046948916
     
    #15 cmileto, Dec 1, 2013
    Last edited: Dec 1, 2013
  16. Xen
    Offline

    Xen Member

    Joined:
    Mar 10, 2013
    Messages:
    73
    Likes Received:
    5
    if you want i can test it in my local server. I have a server without any mods for such kind of experiments but it won't give me any feedback about networking.

    Where could i test it?
     
  17. cmileto
    Offline

    cmileto Member

    Joined:
    Nov 18, 2013
    Messages:
    176
    Likes Received:
    9
    I have tons of crap added so its very possible that something is conflicting. I have double checked my merge and I dont see anything . Though I just found out that all my gargoyle items are screwed up. When you take off a garg shirt forexample it turns into a purple stair ?? I know it wasnt like this before. Im gonna shut the server down and find out whats up with this
     
  18. Xen
    Offline

    Xen Member

    Joined:
    Mar 10, 2013
    Messages:
    73
    Likes Received:
    5
    can i get your chat contact ? So maybe we could fix it together?
     
  19. cmileto
    Offline

    cmileto Member

    Joined:
    Nov 18, 2013
    Messages:
    176
    Likes Received:
    9
  20. Xen
    Offline

    Xen Member

    Joined:
    Mar 10, 2013
    Messages:
    73
    Likes Received:
    5
    i'm trying with a clean version of 54# release. Perfect, it works exactly as it should.
    Is it possible to run a public server of official ServUO release?


    PS. Regnak, are you italian?
    --- Double Post Merged, Dec 1, 2013, Original Post Date: Dec 1, 2013 ---
    OrcGalleon :
    BaseSmoothMultis :
    !IsOnBoard(from)

    This methods has something strange. I'm on board but it doesn't count me as if i'm.
    --- Double Post Merged, Dec 1, 2013 ---
    Gargoylle Galleon is the same, if i enter there with [m tele command it doesn't work. Same error. Tokuno too.
    Only Britain Galleon works as it should ;).
     
    #20 Xen, Dec 1, 2013
    Last edited: Dec 1, 2013
Similar Threads: ServUO SmoothMultis
Forum Title Date
Windows Support Errors during compile OWLTR 4.0 for ServUO Pub 54 Nov 9, 2017
ServUO Discussion ServUO shard login fails Nov 6, 2017
Custom Releases Graverobbing (updated for newest ServUO) Nov 6, 2017
Script Support Ridable Monsters script - adapt for ServUO Nov 5, 2017
Script Support Cannot create servuo server startup Nov 2, 2017
ServUO Discussion Compile ServUO Oct 24, 2017
Custom Releases Xanthos Auction System [ fixed for newer ServUo Repos ] Oct 13, 2017